IPV 6 on Virtual Box

More a statement than a question.
I’m setting up Home Assistant on a Windows 10 PC - I managed to install everything OK but home assistant was not getting an IP address - well a stage one that I couldn’t route to ( a range I don’t use)
I tried setting in manually but that just caused a lockup (may have been me not knowing what I was doing)
I went round in circles for a bit and then out of deseparation switched off IPV6 on the windows PC and it all now seems to work fine!