Is this possible at all or no?

I ve been fighting my HH install for a while now in trying to get something to work and I’m wondering if it is at all possible.

What I want is to use an external activity LED on my raspberry pi 4. I 'm aware of how this can be done using some adjustments to the /mnt/boot/config.txt and after the usual swearing at VI being the only editor available I got it done. Problem is that using an external activity LED works fine as long as you are running from an micro SD card. But I am running from an SSD. And no activity of that SSD is reflected.
Someone wrote a utility just for this purpose ( https://github.com/RagnarJensen/PiLEDlights ) and when run does light up the led on disk activity. Works a treat, I have it running on other pi’s as well.

But, getting to run something on hassos ( or whatever it is called now) is a right pain in the butt. When I SHH into HA ( using port 2222 ) I can use scp to copy the utility to the data mnt for instance ( other mnts seem write only) but it still refuses to execute, keeps saying

/bin/ash: ./actledPi: not found

So… my question is. Am I on a dead end here? Is what I want possible at all? and if so, how ? :slight_smile:

Cheers

Yes you are probably on a dead end when trying to do this with Home Assistant OS. It’s a locked down minimalist and specialised OS.

A Home Assistant Supervised install might be a better option for this.

That is exactly why a lot of people run the “Supervised” or “Container” install option. You have an OS running, that you can control and work with (RaspberryOS or Debian or…). That gives you complete control over your OS and HA is still running in a containerized environment.

Keep in mind, that this installation option is not officially supported (any more), but for now it will be updated and all.

You should also know, what you are doing on the CLI, as this seems to be one of the most reported problems with the supervised install: people don’t know what they are doing at the OS level and thus ruining their HA install. Then HA is called “not working”. :wink: But it seems, you are not unfamiliar with the CLI. :slight_smile:

My advice: make a snapshot of HA, download it. Setup the system new, with RaspberryOS on SSD. Afterwards use the supervised or container install for HA. Get the setup running and then restore your snapshot. Should not take you longer than one or two hours and everything should run again. :slight_smile:

Better then RaspberryOs, install Debian. Supervised on Debian is supported.

https://raspi.debian.net/tested-images/

There is a how-to on the forum.

On Debian it is supported? :astonished: Didn’t know that… What am I waitong for then? :smiley:

But you have to remember that if you run anything at all outside of the HA ecosystem on the OS or in another container that isn’t a HA add-on then it is still unsupported.

Thanks, I’ll give this another go then. Already tried it in the past but ran into update issues with supervisor eventually.

Why is Debian the better option?

It’s stable and popular.
They picked one os to support.

Raspberry Pi OS and Debian are pretty much identical.

Does raspberry pi is run on anything but a raspberry pi?

Technically yes, it’s basically Debian compiled for ARM with some RaspPi specific tweaks, branding and preloaded kernel modules to make it work out of the box on the Pi.

Although RaspberryOS en Debian are almost identical, a Supervised installation of HA is only supported on Debian, so if you create a new installation it is better to go for the supported installation method.

Correct and to be clear, running HA supervised in RaspberryOS most likely would still work. And when it breaks somehow someday in the future, you are probably still fine since we have a forum here - most likely someone here would be able to help.

It’s just that if anyone wants an OS that is “officially supported”, Debian it is.

But Debian for Raspberry is not officially supported by the Debian team… :wink: It’s either way ending in a somewhat “unsupported” system. :slight_smile:

But as you said, there will be someone who will take care of that. I tried it yesterday evening, not very pleased with Debian on Raspberry. I’ll stay with RaspberryOS and an “unsupported” HA supervised install.

For Raspberry Pi4, the ‘beta’ 64bit version of RaspberryOS is detected as Debian by Home Assistant. That is what I’m using on by Raspberry Pi 4 at the moment.

1 Like