Issue pairing GE 12730 fan control

Not sure what is going wrong here, no matter what I try I cant get this switch to pair. I previously had it and dimmer that is right next to it paired to my Abode hub and working fine, I wanted to move them over now that I’ve got my hass running. I first removed them from abode using their exclusion tool, I then went to HASS and to add them, the dimmer added no problem first try but I can’t get the fan control to add no matter what I do

Did you try the “Add Secure Node” button?

I did, same issue

What shows up in your OZW_Log.txt?

2017-09-12 20:53:22.796 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:
2017-09-12 20:53:22.797 Info, contrlr, ADD_NODE_STATUS_LEARN_READY
2017-09-12 20:53:22.797 Detail, Node001,   Expected callbackId was received
2017-09-12 20:53:22.797 Detail, Node001,   Expected reply was received
2017-09-12 20:53:22.797 Detail, Node001,   Message transaction complete
2017-09-12 20:53:22.797 Detail, 
2017-09-12 20:53:22.797 Detail, contrlr, Removing current message
2017-09-12 20:53:22.797 Detail, Notification: ControllerCommand - Waiting

This is when you try to pair the switch?

I always find it useful to do an exclude first on any new device before I do the add, even a new item.

Yeah, I put it in add node or add secure and that’s what I get. It’s like it doesn’t see the switch to be able to pair with it, I’ve tried excluding it first and also doing a manual reset to factory defaults with no luck. The switch pairs fine with my abode hub which sits next to the server with HASS.

Try setting your logger for zwave to debug, may provide more information.
Add to your config:

    homeassistant.components.zwave: debug

then you can tail -f home-assistant.log to get more info on what’s going on when you try to pair it.

1 Like

I know from first-hand-experience that you have to exclude the node more than once. They hold on to the old configuration for some reason. Do it 2-3 times in a row, then try to pair it again in normal mode (not secure). The electrical outlets are even worse than the fan controller.

1 Like

For whatever reason HASS just wasn’t seeing it for exclusion or inclusion. I unplugged my Zstick (I know not the preferred method) and and added it that way with no issues. Strong since its in the same box with a GE dimmer switch that added no problem. Oh well