Issue with installing bluepy for BLE lights

I’m not sure if this is the right spot or not, so please excuse if not.

I have hassio installed on a raspberry pi 3b and so far have been loving it. Everything has worked well with help from this forum. I got a few c by ge ble lights and found some topics on this but the issue I’m having I can’t seem to find a solution for.

One of the requirements is to have the bluepy python module installed but when I try I get a message stating
Error: [Errno 2] No such file or directory: ‘make’

I have tried installing with pip and also from source (python3 build)

I saw solutions to install glib dev tools but that doesn’t seem to be an option with hassio.

Is this something wrong with my install? I have been able to install other things with python and pip.

Home assistant version: 0.117.6
Operating system: 4.16


Having the same issue, have you managed to solve this?

I didn’t. What I did since I had a spare pi was to install ha on top of raspberry pi is on that one to get bluetooth working then added it as a secondary instance under my hassio installation. A little clunky but has been working.

Hi, for guys running HomeAssistant container which is alpine based, I’ve successfully used

pip install --find-links $WHEELS_LINKS bluepy==1.3.0
seen on Bluepy fails to install on 0.94.1 · Issue #24441 · home-assistant/core · GitHub
I personally don’t use hassio supervisor but it may be usefull…