Issue with updating from 2022.11.4 to any newer

currently I am running:

# docker exec -it hassio_cli ha core info
arch: amd64
audio_input: None
audio_output: None
boot: true
machine: qemux86-64
port: 8123
ssl: false
update_available: true
version: 2022.11.5
version_latest: 2022.12.9
watchdog: true

When I try to run any update (core, add on), it failed with this error in a log file:

Logger: homeassistant.components.websocket_api.http.connection
Source: components/hassio/
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 12:52:54 PM (1 occurrences)
Last logged: 12:52:54 PM

[139653532141792] Error updating Home Assistant Core Unknown error, see supervisor
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/hassio/", line 303, in async_install
    await async_update_core(self.hass, version=version, backup=backup)
  File "/usr/src/homeassistant/homeassistant/components/hassio/", line 45, in _wrapper
    raise HassioAPIError(data["message"])
homeassistant.components.hassio.handler.HassioAPIError: Unknown error, see supervisor

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/", line 200, in handle_call_service
  File "/usr/src/homeassistant/homeassistant/", line 1744, in async_call
  File "/usr/src/homeassistant/homeassistant/", line 1781, in _execute_service
    await cast(Callable[[ServiceCall], Awaitable[None]],
  File "/usr/src/homeassistant/homeassistant/helpers/", line 208, in handle_service
    await service.entity_service_call(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 678, in entity_service_call
    future.result()  # pop exception if have
  File "/usr/src/homeassistant/homeassistant/helpers/", line 943, in async_request_call
    await coro
  File "/usr/src/homeassistant/homeassistant/helpers/", line 715, in _handle_entity_call
    await result
  File "/usr/src/homeassistant/homeassistant/components/update/", line 154, in async_install
    await entity.async_install_with_progress(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/update/", line 413, in async_install_with_progress
    await self.async_install(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/hassio/", line 305, in async_install
    raise HomeAssistantError(
homeassistant.exceptions.HomeAssistantError: Error updating Home Assistant Core Unknown error, see supervisor

I am running it on top of ubuntu 18.04. Ubuntu itself seems to be healthy, I didn’t face any similar issue before.
Do you have any hints?
Thank you.

Any repair issues possible and what does the supervisor log say?

Well, as I am using ubuntu 18.04, I have these repair actions

  • Unsupported system - Operating System
  • Unsupported system - Network Manager issues
  • Unsupported system - Systemd Journal issues

I tried to fix them manually, but HA is still reporting these as a issue.

Nothing in supervisor log…

Hmm, I see backup mentioned in the log outputs, so check if you can make a backup.
Sometimes backup integrations, like the Samba backup, can freeze the system, so other backups can not run.
This occur especially when the Samba share have been unavailable at a point in time.
Making sure the share is available, then restarting the integration and forcing it to do a backup by setting the time to some near future point usually reset the freeze state.

Good point - I tried to do the update without backup and still same issue. I tried to run a backup manually and it works just fine. Still struggling…

Ok, I have no clue if the issues mentioned by HA itself will hold it back and I can not guess what else it could be.
The unsupported OS is a hard one to deal with, but the other two should be possible, though still a lot of work.