Issue with Zwave after upgrade to 0.78.3


#1

I have used home assistant for a few months now, but when I upgraded to 0.78.3, I got a new error message from the openzwave component.

2018-09-23 21:59:02 ERROR (MainThread) [homeassistant.setup] Error during setup of component zwave
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/setup.py”, line 145, in _async_setup_component
hass, processed_config)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/zwave/init.py”, line 228, in async_setup
from openzwave.option import ZWaveOption
File “/srv/homeassistant/lib/python3.6/site-packages/openzwave/option.py”, line 29, in
import libopenzwave
ImportError: /srv/homeassistant/lib/python3.6/site-packages/libopenzwave.cpython-36m-x86_64-linux-gnu.so: undefined symbol: PyFPE_jbuf

As you may be able to see, I’m running a virtual environment with Python 3.6.6. I have looked around for the above error message and it seems related to some flags when compiling kivy (other ppl reported this with kivy). Should I try to install python_openzwave manually and with some other flags?
I have installed libopenzwave1.5 and openzwave with apt, but even when I remove them the problem is still there.

Anyone else ran into this? Let me know if there’s some other info I should share. I am running Ubuntu 18.04.1 on a intel core i3 cpu, so no rpi.


#2

Seemed to be related to cached stuff. I solved it by doing the following in my virtual environment:

pip install --no-cache-dir --force-reinstall -U python-openzwave


#3

I’m also getting this error after updating to 0.79. I’m on Ubuntu 18.04.1 as well with a virtual env.

I tried your solution but it didn’t fix the issue for me unfortunately. Still looking.


#4

Did you try to recreate the virtual environment? I’m not sure if it’s related but I did that as well.


#5

I deleted and re-created the virtual env but I still get this error unfortunately.


#6

A Google search for that suggests the problem is a missing numpy


#7

Got this fixed although it’s more of a workaround…

It looks like Home Assistant is installing version 0.4.9 of python_openzwave which my machine has an issue with for some reason. I verified this outside of Home Assistant by running pyozw_check which threw the same undefined symbol error.

I did a pip3 install --update python_openzwave which installed version 0.4.10 and I verified that it replaced libopenzwave.cpython-36m-x86_64-linux-gnu.so with a new copy.

I ran pyozw_check again and verified I no longer got the error.

The thing is when you start Home Assistant again it will overwrite libopenzwave.cpython-36m-x86_64-linux-gnu.so with the old version again.

So my crappy workaround is to remove write permissions on this file so it can’t be overwritten when Home Asisstant starts up. This works for now but I’ll still need to get to the bottom of the issue at some point.


#8

Thanks for posting this – corrected the same issue for me after an apt upgrade on my ubuntu box.