Issues Enabling Bluetooth Hassio Pi3+

Hi All,

I just settled on Hassio for my home and got my new Pi 3 in the mail the other day. I have installed using the Hassio image and it’s all up and running. I haven’t added much to the config yet, just trying to get some of the addons setup.

I have setup SSH, SAMBA and DuckDNS without any issues, but I can’t seem to get the Bluetooth BCM43xx (ResinOS) to enable. I get the below in the log of the addon:

Failed to write reset command
Can't initialize device: No error information

In the Hassio log I get:

18-07-25 01:18:56 INFO (SyncWorker_12) [hassio.docker.interface] Clean homeassistant/armhf-addon-bluetooth_bcm43xx docker application
18-07-25 01:18:57 INFO (SyncWorker_12) [hassio.docker.addon] Start docker addon homeassistant/armhf-addon-bluetooth_bcm43xx with version 2.3

I can’t really tell what the issues is and being new to all this, I am a bit suck. please help!


I’m getting the same issue - need to enable for my Xiaomi Mi Flora component and am stuck with where to go!

Any help out there?

is there a solution?
i install now a new pi with hassio 0.75.3 and hassos_1.9

According the the docs, it is not required for new installs.

`Start this add-on to activate the BCM43xx Bluetooth chipset in the old ResinOS based builds. If you first installed after mid July 2018 then you will have a HassOS based system.

You can identify the base of your system by looking in the System tab of the menu.
This is not required on the new HassOS based installs and should not be installed.`

I have not tested the native bluetooth yet so… I dunno if this helps.

Hey mate, thanks for the tip! Yeah I got my new Pi mid July looking at my invoice and it appears I am running HassOS 1.7. Now to try to get it to discover some bluetooth devices!

Yay, got it to discover some stuff after a removing the BCM43xx Bluetooth add-on and rebooting the system (not sure this was needed, but couldn’t hurt).

For reference, my config looked like this:

  - platform: bluetooth_tracker
    interval_seconds: 15
    consider_home: 150
    track_new_devices: yes

Thanks again dickcollier!


Yes it could - there’s a reason the docs say not to add it if you’re using HassOS based builds :wink:

I can’t seem to locate the BCM43xx package to enable BT on my ResinOS Pi 3, does anyone know why this isn’t available?

There’s no more development (or support) for the ResinOS based builds. I’d plan a migration to HassOS.

Thanks, will have to finally get onboard. Cheers.

the package isn’t nessesery anymore. In ResinOS, BT is automatically activated

I believe you mean in HassOS. I was running ResinOS which required the addon, which looked to be no longer supported and removed from being available; a push to upgrade to HassOS (which I’ve now done). Thanks for the reply.