Issues recognizing Yamaha RX-V483

Hello, I have been struggling getting my Yamaha RX-V483 recognized by home assistant for the last couple of days. Will try to provide as much detail as possible, but my assumption is that I am doing something wrong in the configuration yaml, even though I have tried varieties of both the yamaha and yamaha_musiccast platforms. I have tried host as IP (with and without double quotes, as yamllint suggested), as well as host with host name (case sensitive). Have also tried with and without the host: , name: , and port: fields.

I have made sure network standby is on, per this documentation: https://www.home-assistant.io/integrations/yamaha.

The receiver comes up in entities through my router, and under its host name Living-Room(device_tracker.living_room) - is there a way to link to the device through that entity?

Am I missing something I need to do with discovery? Any other thoughts or possibilities I should be looking into are much appreciated.

Attaching the configuration file i am using for troubleshooting:

media_player:
  - platform: yamaha
    host: "XXX.XXX.XXX.XXX"

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:
  base_url: "https://xxx.duckdns.org"
  ssl_certificate: redacted
  ssl_key: redacted
  ip_ban_enabled: True
  login_attempts_threshold: 3

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

same issue here any solutions?

Did anyone ever figure our if the V483 is supported and works properly with the integration?