Issues updating homeassitant in virtualenv

I followed the Installation in Virtualenv and it works just fine.
I am trying to update home assistant so i ran the following:

$ source /srv/hass/bin/activate


(hass)$ pip3 install --upgrade homeassistant

however, I received the following error:

Traceback (most recent call last):
  File "/srv/hass/lib/python3.4/", line 523, in move
    os.rename(src, real_dst)
PermissionError: [Errno 13] Permission denied: '/srv/hass/bin/hass' -> '/tmp/pip-67k9hg6q-uninstall/srv/hass/bin/hass'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/srv/hass/lib/python3.4/site-packages/pip/", line 215, in main
    status =, args)
  File "/srv/hass/lib/python3.4/site-packages/pip/commands/", line 317, in run
  File "/srv/hass/lib/python3.4/site-packages/pip/req/", line 736, in install
  File "/srv/hass/lib/python3.4/site-packages/pip/req/", line 742, in uninstall
  File "/srv/hass/lib/python3.4/site-packages/pip/req/", line 115, in remove
    renames(path, new_path)
  File "/srv/hass/lib/python3.4/site-packages/pip/utils/", line 267, in renames
    shutil.move(old, new)
  File "/srv/hass/lib/python3.4/", line 536, in move
PermissionError: [Errno 13] Permission denied: '/srv/hass/bin/hass'

Have also made new user as described under step 1?
Then you have to run this first:
sudo su -s /bin/bash hass

yup. so should i run the upgrade as the hass user also?

That did it. Poor oversight on my part.