ITead's "Sonoff Zigbee 3.0 USB Dongle Plus" (model "ZBDongle-P") based on Texas Instruments CC2652P +20dBm radio MCU now sold for $19.99

Oh, the official RPi power supply.

I’m using zha. Up to date home assistant core and os.

The dongle will not let me add any new devices and the Ikea buttons I had 90% don’t work now and are unavailable.

I just tried another sonoff dongle as I ordered 2 and neither allows me to add any new devices. I tried adding an ecosmart bulb, Ikea button and an aqara door sensor.

The dongle is a massive upgrade in network speed for the devices that can connect and a huge downgrade in reliability over the nortek as I never had issues pairing with the nortek or Ikea buttons falling off.

I will add I just got these 2 dongles in their November batch. Not sure if this is a systemic hardware issue. I was troubleshooting with puddly on GitHub and he thinks it’s a hardware issue as well. After restoring my Nvram on his stick and having no issues at all.

I also tried adding decices via repeaters and that didn’t work either even though in the logs when you add a device it said it successfully sent a pairing request to the device

have you tried going back to a sdcard and seeing if the added power needed for the sata ssd or a defective usb-sata adapter was causing some of your problems?
right now im using a 3.5 amp cana. I use my official pi psu to charge batteries an even that job it doesn’t do well because of its plug being so large.

As noted by qooqoo and other, Raspberry Pi and other SBCs can act weird when not got a good PSU.

Maybe test with both older “20210120” firmware version as well as with the latest “20211114” (develop):

https://github.com/Koenkk/Z-Stack-firmware/raw/5adbe76236167e17ee24588e70ba35850f7061ab/coordinator/Z-Stack_3.x.0/bin/CC1352P2_CC2652P_launchpad_20210120.zip

https://github.com/Koenkk/Z-Stack-firmware/blob/7c5a6da0c41855d42b5e6506e5e3b496be097ba3/coordinator/Z-Stack_3.x.0/bin/CC1352P2_CC2652P_launchpad_coordinator_20211114.zip

Note all Koenkk’s older firmware that has been uploaded can be found in the commit history on GitHub:

https://github.com/Koenkk/Z-Stack-firmware/commits/master/coordinator/Z-Stack_3.x.0/bin

Also, are you using a good enough power-supply unit if using the dongle on a single-board computer?

If I just got them from the late November batch I wonder what firmware they shipped with. Is there an easy way to find out?

Not sure if you’re talking to me about having a good power supply as I see there’s another discussion about that. I’m using an odroid n2+ with the provided power supply and I don’t have issues controlling devices just issues with Ikea buttons and adding devices. I have 107 devices and 99% work. I don’t think pairing would draw so much additional power that a power supply issue would be the culprit.

If you have 107 devices and 99% of them work then I doubt your issue is specific to this Sonoff Plus dongle and thus you are more likely to find help by posting a new dedicated thread about it instead. Tip is then to lead with the fact that you already have 107 devices and 99% of them are working fine.

Since 107 devices are quite a lot since there is a limit to how many devices you can have connected directly as direct children to the Zigbee coordinator.

So my first guess is that you either do not have enough “good” Zigbee router devices or that one of your existing Zigbee router devices is giving you issues, so to troubleshoot I would try to join through a different Zigbee router device or maybe even remove some battery-operated devices (if those are direct children connected directly to the Zigbee coordinator) and then re-add them though a Zigbee router device instead after you added more Zigbee routers.

Anyway, remember that there is a limit to how many direct children a Zigbee coordinator can have, and understand that proper use of Zigbee router devices is essential in a Zigbee network. Recommend read all these general tips which are all directly or indirectly related to proper use of Zigbee routers:

https://www.home-assistant.io/integrations/zha#best-practices-for-avoiding-pairing-difficulties

https://www.home-assistant.io/integrations/zha#using-router-devices

https://github.com/home-assistant/home-assistant.io/pull/18864

Regarding IKEA buttons you should check out this blueprint → ZHA - IKEA TRADFRI - 5 Button Remote - Custom Actions

Help is by the way still wanted testing firmware upgrade(s) with pull request patch for ITead’s Sonoff CC2652P USB dongle with JelmerT cc2538-bsl tool using the new option --bootloader-sonoff-usb

https://github.com/JelmerT/cc2538-bsl/tree/feature/ITead_Sonoff_Zigbee-delay

Please report firmware upgrade issue with it or confirm it working under which operating system here:

https://github.com/JelmerT/cc2538-bsl/pull/114

(There is a longer related troubleshooting discussion in https://github.com/JelmerT/cc2538-bsl/pull/114 )

Note that for ZHA it is recommended to always do a backup before upgrading the firmware, see links in:

https://community.home-assistant.io/t/zha-integration-to-do-nightly-backup-of-both-zigbee-coordinator-adapter-dongle-stick-and-zigbee-database/357558

Personally I recommended doing backup with zigpy-znp then restore backup after upgrading firmware.

All of them worked with a nortek stick which is from 2015. There’s no reason it shouldn’t work now. The only 1% of the issues I am having are Ikea buttons and not being able to add any devices. The Ikea shades of which I have 13 work perfectly fine. The majority are ecosmart zigbee bulbs that are routers and again everything worked fine on nortek no issues.

After a firmware update do I need to restore the network configuration again?

Updating the coordinator firmware to the latest November developer firmware and updating to zigpy 0.6.3 at the same time appears to have fixed the ability to add devices. I was able to pair 2 devices that previously were not pairing. Time will tell as to whether it also solves the battery drainage issue on the Ikea buttons.

I managed to flash the latest KoenKK router image to the sonoff sticks I have, and they seem to work well as routers. However in deconz I notice the name of the device is set to the MAC address and is not changeable like other devices (including the tradfri repeaters I have).

Is there a way to change this, as labelling it by deployed location makes it easy to remember where I put these things.

Using a couple of RPI4 4GB with these Drive Enclosures and 120 GB Kingston SSDs, ZigStar or Slaesh sticks connected to the Pi’s through 1.5m USB extension cables together with the original RPI4 PSUs and never ever experienced a single failure/freeze on even one of those combos a year or so!

1 Like

Looks like the newest batch has the Product Description

2 Likes

Never said the failure was due to the psu. I said it was more likely a defective usb sata adapter or a power/voltage change. then said the plug was large. Glad you like yours. Also even without knowing what ZigBee USB adapter your using I can easily tell it probably uses a little less power than this one that we are actually discussing.

First of all, should really make sure have a backup before firmware upgrade of a Zigbee Coordinator.

You should not have to pair any devices again, however, if end up having to restore backup then could take up to 24-hours before all devices have connected (especially battery-operated devices like sensors which usually only connect upon sensor changes).

If any device that was connected before is still not connecting after firmware upgrade then should be enough to power-cycle those devices (e.g. unplug and replug mains-power, remove and replace battery).

Naming in an application depends on software implementation so you would really have to ask such questions deCONZ community / Phoscon community forum → https://forum.phoscon.de and/or Home Assistant’s deCONZ thread → https://community.home-assistant.io/t/deconz-official-thread/100504

That sounds promising! Can you check and verify the exact product description they choose to go with?

Also, can you test the changes from this pull request:

https://github.com/home-assistant/core/pull/58166

It uses wildcards I think it will work as long as the product description contains “sonoff” somewhere(?).

Looks like usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_201e5if00-port0

I assume that is just the assigned serial port in Linux and not the product description value that was written to the product description field in the EEPROM of the CP2102N USB-to-UART chip by ITead.

Not sure on Linux but on Windows can use tools like ex. NirSoft USBDeview or Sieber USBTreeView:

https://www.nirsoft.net/utils/usb_devices_view.html

http://www.uwe-sieber.de/usbtreeview_e.html

Note! Sometimes it’s call it “Product Description”, other times “Device Description” or just “Description”.

Previous batches the description show as “Silicon Labs CP210x USB to UART Bridge” in those tools:

These pictures were taken from the Hardware section in HAOS

Old ID

/dev/serial/by-id/usb-Silicon_Labs_CP2102N_USB_to_UART_Bridge_Controller_a4766cbfb593eb11b7611b4f3d98b6d1-if00-port0

New ID

/dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_201e5if00-port0

1 Like

Would having 2 of these as routers and 1 as the coordinator cause interference between them? And would other repeaters and end devices latch on to these routers given their better signal because of their antenna?