ITead's "Sonoff Zigbee 3.0 USB Dongle Plus" (model "ZBDongle-P") based on Texas Instruments CC2652P +20dBm radio MCU now sold for $19.99

Me too, page is down for several days and couldnt find an outside download, everywhere links to ti’ site :thinking:.
You could use the other method, via python script.

The device its supposed to work as router, as stated by Itead (00:43 mark):

https://www.youtube.com/watch?v=ol6ElGcSAgc

Dear all, I was having the same issues with the TI registering page being down.

I managed to get a copy thanks to this page:

to the rigth you will find several downloading options. The zip one is the one I used.

Regards

4 Likes

Thanks man, you saved my day!

You are welcomed!

Hello,

I bought a Sonoff zigbee dongle with the intention of replacing a CC2531. However, the Sonoff dongle does not work correctly with two zigbee smart plugs that already exist in the network - I can’t turn them on/off remotely. Other sensors (door, movement) all seem to work OK. I have tried removing and re-pairing the plugs, different firmwares for the dongle (including the latest dev) and Z2M Edge, but nothing seems to fix the problem.

Any ideas? The plugs are Tuya and Blitzwolf (Tuya clone).

Thanks for any help!

Has anyone gotten one of these to successfully act as a router? I’ve tried flashing coordinator, clearing NVRAM then flashing router. I’ve tried both ZHA and Z2M. All without the ability to pair.

I think it may be a sign the network is too noisy. I had this issue and I removed the antenna and it paired instantly. I ended up realizing I didn’t need them as routers as my lights were latching on to the router that was further than nearby lights and completely destroying the strength of the network.

1 Like

Today was released a new z2mqtt release fixing bugs, and new firmware:

https://github.com/Koenkk/zigbee2mqtt/releases/tag/1.22.2

I haven’t upgrade the firmware yet, I am using the default one that came with the dongle (20210708) as coordinator and by the moment there is no problem (upgraded from CC2531)-

1 Like

Did the z2m update from today fix it? It fixed my blitzwolf plugs.

Thanks for hint. Just tried it…but no luck, unfortunately. Same problem, the plugs won’t respond to commands. Tried a reconfigure, but that generates a “zigbee publish error”.

Switched back to the old dongle, no problem at all with the plugs.

2 Likes

I flashed the router firmware to the dongle. How do I add it to my network?

Once they boot up they are in pairing mode. Have deconz of z2mqtt initiate pairing right after you power the node up and it should join just fine. I use 3 of these as repeaters in my deconz network. It would be nice to find a way to set the tx power levels when in router mode.

3 Likes

That worked. I started the pairing before plugging it in.

Just putting my experience out there. While coordinator has worked great on any channel, I’ve had a lot of trouble with the sonoff dongle joining as a router when the network was on channel 25. Was wondering if anyone else has experienced a similar issue? Channel 15 working fine but 25 not so much.

Update! Z-Stack 3.x.0 20211217 release has now been copied to master and should be seen as stable:

https://github.com/Koenkk/Z-Stack-firmware/tree/master/coordinator/Z-Stack_3.x.0/bin

https://github.com/Koenkk/Z-Stack-firmware/blob/3275288c3a9497b4073604156e887778485c1b34/coordinator/Z-Stack_3.x.0/CHANGELOG.md

Again, recommend using JelmerT’s sonoff branch here to upgrade firmware without pressing buttons:

https://github.com/JelmerT/cc2538-bsl/pull/114

Hopefully ITead will begin pre-flashing this release to future batches for +9 dBm out-of-the-box support.

PS: This new firmware version is also shipped as standard as part of Zigbee2MQTT 1.22.2 release

If the default Zigbee channel is conflicting with your Wi-Fi channel then you should really consider changing the channels on your Wi-Fi router and/or access-points instead as per the suggestions here:

https://github.com/home-assistant/home-assistant.io/pull/18864

https://github.com/home-assistant/home-assistant.io/pull/18864/commits/b21c49589d898d60a1a235afa7b9c148d013cfee

It is generally recommended not to change Zigbee channel on your Zigbee coordinator from default as not all Zigbee devices will initiate pairing on all channels. There are some mentions of this on a few specific devices listed in blakadder’s Zigbee Device Compatibility Repository so maybe add a comment:

https://zigbee.blakadder.com/

https://zigbee.blakadder.com/Sonoff_ZBDongle-P.html

Example:

https://zigbee.blakadder.com/Legrand_064873.html

Some Legrand devices work only on Zigbee channel 11. With certain devices you need the Legrand Hub to update the firmware to have all features available.

Regardless, probably also want to report any such issues to this Z-Stack firmware development repo:

https://github.com/Koenkk/Z-Stack-firmware

https://github.com/Koenkk/Z-Stack-firmware/issues

Hello!
I also messed up the SONOFF USB ZIGBEE after router firmware the flash.
Unfortunately, flash again doesn’t work at all.

D:\Utils\cc2538-bsl-feature-ITead_Sonoff_Zigbee-delay>cc2538-bsl.py -p COM6 -evw --bootloader-sonoff-usb CC1352P2_CC2652P_other_coordinator_20210708.hex
sonoff
Opening port COM6, baud 500000
Reading data from CC1352P2_CC2652P_other_coordinator_20210708.hex
Your firmware looks like an Intel Hex file
Connecting to target…
ERROR: Timeout waiting for ACK/NACK after ‘Synch (0x55 0x55)’

Is there another solution to the problem, or has USB become completely brick?
Thanks!

Yeah should use “CC1352P2_CC2652P_launchpad_*.zip” and not “CC1352P2_CC2652P_other_*.zip

https://github.com/Koenkk/Z-Stack-firmware/tree/master/coordinator/Z-Stack_3.x.0/bin

Did you try removing enclosure and manually hold physical boot-button while plugging into USB-port?

https://sonoff.tech/sonoff-zigbee-3-0-usb-dongle-plus-firmware-flashing-2/

If you messed up the bootloader firmware then only way to unbrick the hardware is to flash with cJTAG:

https://electrolama.com/radio-docs/advanced/flash-jtag/

The cheapest option for an officially supported debugger is Texas Instruments CC-DEVPACK-DEBUG:

https://www.ti.com/tool/CC-DEVPACK-DEBUG

The official TMDSEMU110-U XDS110 JTAG Debug Probe is better option though as offer more options:

https://www.ti.com/tool/TMDSEMU110-U

Texas Instruments XDS110 JTAG debug probe is a bit expensive but cheap clones of it should work, ex:

https://aliexpress.com/item/4000751867419.html

Also, note that original Segger J-Link V9 (legacy) debug probes does not support cJTAG, so need at least a Segger J-Link V10:

https://wiki.segger.com/J-Link_Model_Overview

Where exactly can the output power setting be increased to 20dBm after flashing ‘CC1352P2_CC2652P_launchpad_coordinator_20211217.hex’ which has the output set to 9dBm by default?

1 Like