Its posible a dashboard with all the addons?

Hello.
I use core fore more than one year and im happy.
But now I migrate to a OS version with dedicate hardware.
I use a lot of addons and all apears in the left bar. I know i can disable in the left bar. but i have a idea, maybe a stupid idea :stuck_out_tongue:
Its posible to create a dashboard, only 1 dashboard called “addons” in the left side.
And in this dashboard put one slide for each addons.

With this dashboard you can have all the addons in a single side, and mantain clear the left side of the home assistant.

do you understand my idea?

1 Like

Just add an entities card with links to the add-on UI

type: entities
title: Add-On
show_header_toggle: false
entities:
  - type: weblink
    name: Z-Wave JS
    url: http://assistant.house.com:8123/a0d7b954_zwavejs2mqtt/ingress
    icon: mdi:home-assistant
1 Like

thanks @FriedCheese this is a good idea but not the idea i was thinking.
My idea its have 3 tabs (for expample) in the dashboard.
In first tab the entire frigate portal
in second tab the entire zigbee2mqtt
in third tab…

with your idea, i have a "access panel for each entire addon portals, but not the portal

1 Like

What about just using a webpage card then?

  - title: Z2M
    path: z2m
    badges: []
    panel: true
    cards:
      - type: iframe
        url: http://assistant.house.com:8123/45df7312_zigbee2mqtt
        aspect_ratio: 100%
1 Like

great!!
this is better option, but not perfect! jeje

usin this url: http://assistant.house.com:8123/45df7312_zigbee2mqtt
in the frame apears the latteral panel of home assistant. So i can see it duplicate, one in the web and one in the frame.
Exist other url that only show the addon? without the lateral?

thanks a lot man!

1 Like

Maybe figured it out.

If you go to the add-on page and use the page inspector, you should have an iframe with the URL for just the add-on panel:

Use that link for the dashboard card. You’ll need to add the rest of the path to your HA.

http://assistant.house.com:8123/api/hassio_ingress/###restOfToken###/
2 Likes

I love youuuuuuuuuuuuuuuuuuu

Thanks a lot @FriedCheese
really thanks!!
this is perfect for me!! and works!!

EDIT:
WORKS perfect except with “visual code server” that when i push right click not apears the developer options. Any idea @FriedCheese ??

1 Like

Let me load the add-on and see what I can see.

1 Like

You’ll need to right-click right next to the title at the top:

done!!!
thanks again!!
it works!!
the upper bar not apears until I push “open web interface” from the addon in settings.

1 Like

BAD NEWS
when reboot home assistant, the “token” changes and all the dashboards show this message “401: Unauthorized”

:frowning:

EDIT:
the token not change!!! but you must enter one time by the lateral menu, and then. the unauthorized messages dessapears :open_mouth:

Looks like there’s a session cookie with a short lived expiration. My guess is that the cookie gets refreshed/cached when navigating to the add-on using the lateral menu, but that doesn’t happen when trying to load the iframe directly.