I've somehow lost HASS.io, but Home assistant is still working fine. Help?

So my HASS.io menu item (left hand side of screen) has disappeared, and when I check the System Health screen, it shows ‘hassio’ as ‘false’. I’m running Docker, with Hass.io on that, set up using the script - https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh

I also keep getting login attempt failed notifications for 172.30.32.2, which I’ve read in another thread comes from docker.

My setup was working perfectly until last night. Only two things could have caused it -

  1. I was trying to update something else in Docker, so did an update via Docker compose (which includes HA/Docker)
  2. I had a power outage for an hour or so, which obviously took down my server, and everything else.

I’m guessing that it’s #1 above. I’ve updated HASS.io in Docker successfully using the built-in HASS.io updater. However, this is the first time that I’d run my Docker compose file, since I’d moved to HASS.io in Docker

I tried to run the installation script again and got an error, which probably isn’t surprising given that it’s already installed.

I do have backups - should I just trash all of my containers and start again?

Look in the hassio logs for errors.

That is your problem right there. You have overwritten hassio with standard home assistant. You cannot install/run Hass.io with docker-compose.

I suspected that may have been the case. Thanks. I’ll try to undo my mess later today.

That fixed it. Thanks again.

The silly thing is that I found my notes from when I installed Hass.io on Docker, and I’d noted that I needed to remove Home Assistant from my docker-compose file, but obviously never did it!

1 Like