Jasco 45856 light switch recognized by Zigbee Dongle, but status shows unavailable

I boiught a smart light switch, GE I think but it shows up as Jasco 45856. It’s a non-dimmable switch. I installed it in the wall replacing an old dumb switch, it’s powered with a neutral, the blue light works.

Earlier I had it working, pressed the switch and heard the relay click, Sonoff smart plugs which were paired with it in an automation turned on and off. But now, the blue light is not on. It does flash for a bit when I press the ON button 10 times. No click, and the control is greeked on the device info. Says sensors unavailable in the device info. Tried to reconfigure, Binding and Reporting came up with green checkmarks, but then it said that the re-configuration failed.

I re-booted, tried to re-configure, and got this error. I have no idea if this error is related to the attempted re-configuration:

Logger: homeassistant.components.zha.core.channels.base
Source: components/zha/core/channels/base.py:486
Integration: Zigbee Home Automation (documentation, issues)
First occurred: 12:45:45 PM (2 occurrences)
Last logged: 12:45:46 PM

  • [0x6D27:1:0x0006]: async_initialize: all attempts have failed: [DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’), DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’), DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’), DeliveryError(‘Request failed after 5 attempts: <Status.MAC_NO_ACK: 233>’)]
  • [0x6D27:1:0x0702]: async_initialize: all attempts have failed: [DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’), DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’), DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’), DeliveryError(‘Request failed after 5 attempts: <Status.NWK_INVALID_REQUEST: 194>’)]

When I go into the Zigbee device, it shows 4 devices including the Jasco switch. Does that mean it’s paired? And why is it not active?

Need the following:

How far is the switch from your zigbee coordinator (stick)
Do you have any other zigbee devices?
Are the other devices battery or line powered
What is the manufacturer /model (yes model number matters) for your Other zigbee devices.
Is your zigbee stick plugged DIRECTLY into your HA box or are you using some kind of USB extension / USB hub?
What Zigbee channel is your zigbee network using (ZHA or Zigbee2MQTT should be able to tell you)
What channel(s) is/are your 2.4Ghz wifi network using

Good questions.

The switch itself is a GE ZigBee In-Wall On/Off Smart Switch with Energy Monitoring and HA1.2 Certification, 45856GE. That’s taken from the Amazon site.

I have 3 total Zigbee devices, the two smart plugs work. They are the S31 Lite. The switch is the farthest one, about 40 feet but between floors.

All line powered.

The USB Zigbee key is a new Sonoff Zigbee 3.0 USB, attached directly to the ODroid N2+ via an extended USB cable to keep it away from the Odroid.

My home wifi is on 5 Ghz-1 on channel 144 and 5 Ghz-2 on 44. It is also on 2.4, channel 1.

I cannot find the Zigbee channel anywhere, I looked under Devices, Zigbee, info. I am a complete novice on this, but I’ve looked everywhere, and Googled as well.

Hopefully you can answer this. I believe it’s likely distance, and I’ve ordered a Sonoff range extender that is coming tomorrow. But my question is, if Zigbee sees it as a connected device, why does the device itself not see its sensors and the switch itself is greeked?

Does your switch work normally if you just press it manually? If so you might want to try getting more mains powered repeaters in between the hub and your switch. If not the switch could be bad. I’ve had issues with older Jasco GE ZWave switches (and only switches, have never had a dimmer fail) having premature deaths and they no longer function manually when did die. They would just give the occasional blinking blue light…

Speaking of older, if you bought those recently, those GE switches are their older models. The new ones they make now are the QuickFit models but aren’t marketed under the GE brand anymore. They’re usually under the name Enbrighten or UltraPro (which I think is just for their ZWave but not sure) on amazon and I would recommend them because they have better compatibility with battery powered devices like Aqara. They’re also considerably easier to fit in electrical boxes, particularly multi-gang boxes.

Many online say the Enbrighten have a problem, and they blame it on Simplewire where it auto-detects the line and load. So I’m not sure that’s the solution.

Thanks. that helps.

If your switch works at the switch and does not work remotely (which of im reading what you put correctly seems to be the case.) it’s almost always a range issue.

So the spec says 100’

Spec v. Reality is MUCH different. I’ve never been able to get more than 50’ in the BEST circumstances because walls, people, wires, books, floors, plants, pets are all things and they all dampen signals.

Because of this I use 25’as MAX range between repeating nodes. Yes my Zigbee mesh can be seen from space. I call it the Clark Griswold rule…

You don’t need a dedicated repeater for this MOST line powered devices are repeaters with a few notable exceptions. (sengled bulbs) so start with ensuring you have powered nodes every 20’ out to that switch. After you do you may need to run a Zigbee heal routine (or just rejoin that node) to get it to actually use the repeaters (zigbee nodes don’t attempt to find a new parent of the existing parent is reachable)

With as few repeaters as you have that sounds like what’s going on. But just to help…

You will find the zigbee channel in your setup files if you place repeaters and rejoin that switch and it STILL gives you trouble then we can start looking at WiFi or some other interference. (wifi2.4 shares rf range with zigbee)

Finally no matter what add a short usb extension to your dongle - get it off directly being plugged in the box because guess what- USB3 and in particular, USB3 SSDs are horrible for interference in the 2.4Ghz range. Just a half meter extension or a small powered USB2 hub can hell eliminate that

So if im you im buying a bunch of line powered plugs and putting them between HA and the GE plug giving you the issue.

Thank you. Where are these setup files where I can find the wifi channel being used?

If you have not changed anything then ZHA sets up on Zigbee 15 by default. (sounds like you have not changed it.)

Its relevant because of this:

Zigbee 15 is NOT WiFi 2.4 - 15 they’re separate arbitrary spaces. But the important thing is see above how wifi 1 (the big blue shape) overlaps on the top end of its spectrum with zigbee 15?

It would in effect dampen your range even more. (imagine screaming at your friend on the dock but still unable to communicate because a cruise ship is laying on its horn, wifi is an order of magnitude stronger than zigbee and always wins in a signal interference fight.)

If you could switch your 2.4Ghz wifi to 11 it might also help, but you still need the repeaters…