Jasco / GE / Enbrighten Dimmer Switch 43080 doesn't turn on after transitioning off

I’ve discovered an odd issue with this switch, and I’m not sure if the problem is something in Home Assistant / ZHA or in the switch firmware.

  1. Turn on the switch to full brightness.
  2. Issue a light.turn_off command to the switch with a transition time, such as 3 seconds.
  3. At the physical switch, tap the on button to try to turn on the switch.
  4. The switch registers as on in HA, but the light won’t actually turn. The blue light on the switch will stay on, indicating the switch itself doesn’t think it’s on.
  5. Workarounds include pressing and holding the on half the switch to increase brightness, or turning the switch on with a ZigBee command. The issue only happens when you try to use the physical button.

Anyone else seen this with zigbee2mqtt or deconz? If so, that would indicate an issue with the switch firmware.

That’s likely more a problem with the light, imo.
My random guess is that the transition plainly reduces the brightness to 0, then the light is switched off.

When the light is turned on without brightness indication, it would just turn on to the latest one, which would be 0 in this case.

Does it happen as well if you remove the transition?
What bulb manufacturer/model is it?

Looks like it comes on with brightness set to 1:

supported_color_modes:
  - brightness
color_mode: brightness
brightness: 1
off_brightness: null
friendly_name: Dining Room Light
supported_features: 41

It looks like the switch considers 1 to still be off (as it leaves the blue LED on), and 2 or greater to be on.

The bulbs are all regular Luminous LED bulbs - it’s only the lightswitch that’s connected via ZigBee.

If I remove the transition, the switch works as expected when turning back on. I think my next step will be to contact Jasco and see if they are aware of this issue.

Ah, ok. Good to know. So the dimmer is actually recognized as a light.

I see that Z2M ticket, which seems similar. Hue light turning on with 0% brightness using Home Assistant service (re-open) · Issue #3799 · Koenkk/zigbee2mqtt · GitHub
Assuming you’re using it, the fix/workaround seems to set the transition in Z2M rather than in HA

I ended up working around this by setting an automation that listens for the light turning on, and then transitions it to full brightness.

In practice, I think what’s happening is that the bulbs don’t activate at such low power from the dimmer. Ideally, this would have been solved by zha’s “off brightness” attribute, but that’s only applied if you turn on the switch from within HA itself.