Json Post command from dasher not working

Hi,

i do not know why this is no more working but for any reason it does not work anymore.
While checking with dasher i can see that it recognizes the Dash button, so i should fire up the command, but nothin is happening, what do i miss?

Dasher: https://github.com/maddox/dasher

   {
"name": "Dash Button3",
"address": "xx:xx:xx:xx:xx:xx",
"url": "http://xxx.xxx.x.xx:8123/api/services/switch/toggle",
"method": "POST",
"interface": "eth0",
"headers": {"x-ha-access": "xxxxxx"},
"json": true,
"protocol": "udp",
"body": {"entity_id": "scene.all_lights_off"}
  }

Hope someone can help me out here.
Regards
Crey

Try removing the "interface": "eth0", and see if that helps. It will then search for all the available interfaces.

Hi,

thanks for answering, but this does not help.
Maybe there is a log i can see if there is something coming in ?

Small push here, hopefully someone can help here.

Is there a way in HA where i can see that there was a post request or not ? So i could see why it was maybe not accepted

Try without the protocol udp line.

Test using curl from the command line.

curl -H “Content-Type: application/json” -X POST -d ‘{“scene.all_lights_off”}’ http://xx.xx.xx.xx:8123/api/services/light/turn_off

HI,

i tried this:

curl -X POST -H "x-ha-access: xxxx" -H "Content-Type: application/json" -d '{"entity_id": "scene.all_lights_off"}' http://xxx.xxx.xxx.xxx:8123/api/services/light/turn_off

Does not work, i even do not get any response.

While the following is working fine

curl -X POST -H "x-ha-access: xxxxx" -H "Content-Type: application/json" -d '{"entity_id": "light.kratzbaum"}' http://xxx.xxxx.xxxx.xxx:8123/api/services/scne/toogle

If i toogle the scene over the gui, it works fine.

Hi,

i have to push this up again, sorry, i am still not able to get this back to work.

Hopefully someone can help

I don’t know if a scene can toggle??? I do know you can toggle a light using the api. Do you have something that does work with the dash button?

After some days here is a small update

From my new internet provider i goot a new router.
After i changed it back to a Fritzbox, it is working fine now.

I only changed the router, nothing else, so it looks like teh cheap router did have had any issues with it.
I am not able to say what kind of issue.

The problem is solved.
Thanks for all the help.

1 Like