Kira Installation fails

Hey guys,

just tried to install Kira but get an error:

Any clues anyone? It seems that a module called pykira is missing?

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 257, in _async_setup_component
    result = await task
  File "/usr/local/lib/python3.10/concurrent/futures/thread.py", line 58, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/kira/__init__.py", line 134, in setup
    load_module(CONF_SENSOR, idx, module_conf)
  File "/usr/src/homeassistant/homeassistant/components/kira/__init__.py", line 119, in load_module
    module = pykira.KiraReceiver(host, port)
  File "/usr/local/lib/python3.10/site-packages/pykira/receiver.py", line 34, in __init__
    self._socket.bind((host, port))
OSError: [Errno 99] Address not available

No. It says the IP address you indicated is not correct.
I assume it’s for sensors? Then leave the host binding address at the default (0.0.0.0)

Hey Chris,

thanks for your swift reply.

My config has:

# Kira configuratie
kira:
  sensors:
    - name: kira_sensor
      host: 192.168.1.216
      port: 65432
  remotes:
    - name: kira_remote
      host: 0.0.0.0
      port: 65432

And my Kira setting is like this:

So to me that looks correct or am I missing something else?

Did you have a good look at the help page?

# Example configuration.yaml entry
kira:
  sensors:
    - name: kira_sensor
      host: 0.0.0.0
      port: 65432
  remotes:
    - name: kira_remote
      host: 192.168.100.1
      port: 65432

You’re doing it the other way around.

Kira - Home Assistant (home-assistant.io)

Ahh thanks Chris!!!

I donor want to use the remote and misunderstood the example as not using the sensor so I changed the host address. Now they appear and I can hopefully take the next steps!