KNX Switch doesnt keep state in UI

Hi all!

I have a problem with the KNX binding.
I can switch a light on in the Dashboard, but the switch itself is toggling back within some seconds.
The actual lights are on, and on the bus, there is only one package in the group for switching it on.
I have configured the switch with only a group address, including a physical switch and an actuator “port”.

The KNX device itself is configured as Tunnel device with UDP (not NAS).
I’ve also tried switching it to router and enabling UDP with NAS but doesn’t help at all…

Hope I can get help from the community :sleepy:

Kind regards,

Hi :wave:!
Can you please copy&paste your configuration yaml for that switch here together with either

  • a ETS GroupMonitor log or
  • a HA log with xknx.telegram set to debug (see KNX integration docs at the bottom)

when switching the switch?

What HA version are you using?
Are there any errors in the logs?


Here are some more informations. :slight_smile:
Home Assistant 2022.9.4
Supervisor 2022.08.6
Operating System 8.5
Frontend 20220907.2 - latest
Error in the logs:

* L_DATA_CON Data Link Layer confirmation timed out for <TunnellingRequest communication_channel_id="89" sequence_counter="5" cemi="<CEMIFrame code="L_DATA_REQ" src_addr="IndividualAddress("15.15.2")" dst_addr="GroupAddress("1/0/0")" flags="1011110011100000" tpci="TDataGroup()" payload="<GroupValueWrite value="<DPTBinary value="False" />" />" />" />

Sounds like to be the problem, but WTF? :smiley:


Sounds like you are loosing your connection every couple seconds.

Oh lol… I just had a look at your edit

Here are some more informations. :slight_smile:
I am using the latest Hyper-V disk of HA.

Kill it with fire!
See KNX L_DATA_CON Data Link Layer confirmation timed out · Issue #75389 · home-assistant/core · GitHub and other issues caused by Hyper-V lately.

I was working the whole evening at this, and can’t get it to work…
I found this thread after i posted my answer, but I can’t find any real solution.
Unfortunately, I need to let it run on a Hyper-V instance. :disappointed_relieved:

I am also using Windows Server 2019 - so the solution with uninstalling doesn’t apply to me…

Sorry, I have no idea about Windows. Maybe you can file a bug with Microsoft for that somewhere (but I would guess someone already did that…)

A workaround for KNX would be to use TCP - if your Knx IP interface supports it.

Other than that Knx/IP just relies on that type of UDP frames Hyper-V seems to just drop 🤷

Seems there is a workaround Turning off hardware checksums for tx. See Windows 10 Hyper-V, networking issues after updating with KB5015807 - Microsoft Q&A

You saved my day! Thank you so much! :hugs:

I did the following steps:

  1. Logging in to the HA docker container:
docker exec -it homeassistant /bin/bash
  1. Adding the “ethtool” package with apk add ethtool - don’t know if that actually was necessary.
  2. Executing the command as described in your link:
ethtool -K eth0 tx off

Finally it is working as it should! :partying_face:

1 Like

lol… :crazy_face:
I got a notification that an update is available, so I made that - for HA OS.
After this update, I got the same behavior as seen before.
Unfortunately, executing the commands mentioned before doesn’t work anymore.
In the log file, I get the same error message as before my initial fix…

L_DATA_CON Data Link Layer confirmation timed out for

Damn it, how could that be!? :disappointed_relieved: