Kwickset 888

Does anyone have a Kwikset 888 working in their configuration? I just got one to try out, looked at the 912 post on here but things look a bit different, and it’s been awhile since I dusted things off and messed with my configuration.

I have it added to Zwave, I can see it in states, it looks like it paired correctly. When I hit the lock / unlock it doesn’t do anything. Anyone have any ideas?

I just installed one of these and it seems to be working out-of-the-box with HA 0.89.1 the lock/unlock works fine from HA. I haven’t figured out how to set user access codes yet though. The Kwikset Installation documents reference a Programming Guide available on their website but the document doesn’t seem to exist. I find docs for 910, 912, 914 and 916. Alas.

A couple things I can think of that might be affecting you:

  • Make sure you run the “door handling” procedure
  • Make sure the lock is included as a secure device (Add Node Secure) and confirm that “is zwave plus” is showing “true”.

Update: The user codes will not work until you have successfully performed door handling. Then you can set codes using the keypad. I still haven’t gotten it to work to set / delete user codes from the ZWave control panel. It acts like it works but then later it shows that nothing was changed on the lock.

I got it, had to remove the zwave entitity, reboot re-add then when I had it generate the key it no longer threw an error. Re-paired the lock and got controls. Followed the thread on here for the 912 lock and got elements displaying the battery level unlock status etc. Recently have an alert push to me if the door is locked after sundown.

1 Like

Did you ever get HA to edit/add/remove user codes for this lock? Looking to get it but want to make sure I can do that from HA first. Thanks!

I just tried it now, and it (still) isn’t working. Bummer.

Configuration > Zwave > Nodes > Kwickset > Node user codes

I see the existing codes, but when I try to add new codes, it tries to save them, but nothing changes.

I try to set a code into an empty slot, using the Hex Code, e.g.: \x31\x33\x31\x31 should set a code of 1-3-1-3, but after hitting save, it refreshes and shows empty again \x00\x00\x00\x00 and the code is not recognized on the lock.

1 Like

On my Kwikset 914, theres a service that is used to set user codes: lock.set_usercode which works well. Have you tried that?

Finally got around to trying this on HA version 0.109.5, and it doesn’t work on my 888. lock.get_usercode works to fetch existing codes from the lock and displays them in the core log (as long as ZWave logging is set to info or higher). Unfortunately, lock.set_usercode seems to be a no-op.

First post in the Home Assistant Community and also I’m a one week new born to Home Assistant.
I was able to set user codes with help of PlayedIn but there was a trick to it.

  1. Configuration > Zwave > Nodes > Kwickset > Node user codes
  2. Go to the slot you want to set and click set Usercode
  3. Heal Node
  4. Developer Tools > Services > lock.set_usercode
  5. Call service

I think I swapped step 2 & 3 but I was able to add 4 user codes this way. Upon adding user code #5, this method stopped working. Let me know if you can perfect my recipe to add a user code.

UPDATE: I think an issue that may have impeded the process for me is that my Wink is still on. Just got a notification that my lock connected to my Wink. It is still on my HA setup as well. Can’t wait to destroy this white brick :slight_smile:

I have one of these installed. It is paired with HA, but I do not get any functionality. The Lock/Unlock buttons do not work from HA and I do not have access to user codes.

What I have done:

  • Added network security key to Zwave config. I believe this is working as I have the following in my OZW log:

2020-06-02 14:15:54.451 Always, OpenZwave Version 1.4.3469 Starting Up
2020-06-02 14:16:06.950 Info, Setting Up Provided Network Key for Secure Communications

And the zwcfg.xml has:

Node id=“15” name="" location="" basic=“4” generic=“64” specific=“3” roletype=“7” devicetype=“768” nodetype=“0” type=“Secure Keypad Door Lock” listening=“false” frequentListening=“true” beaming=“true” routing=“true” max_baud_rate=“40000” version=“4” secured=“true” query_stage=“Complete”

  • I excluded it from the network, rebooted HA, factory reset the lock, and then included it again, twice.

Any ideas?

did you ever get it working? I am trying to get mine working with the new beta zwave integration and cant get it working at all either. it adds to the network but it s ays its not secure (even though i def secure joined) and it doesnt update or lock/unlock or anything.

Haven’t been able to find a solution. I’m still waiting for an HA guru to come along and show me the light. :slight_smile:

I cant get mine to work either. Found this and am hoping once this gets approved and added to the DB it’ll make the lock work. Anyone know how long that process takes?

code got merged and 888 showed up in the device database. I rebooted my HA Pi and now lock and unlock work!! Also shows battery level.

Just FYI. I was having trouble getting my lock to pair with my system. My problem was that my security key was in lower case letters instead of upper case.

    usb_path: /dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_3140033F-if00-port0
    network_key: !secret zwave_network_key 

in my secret.yaml file.

    zwave_network_key : "0xFF, 0xFE, ..."

So 16 bytes long, capital letters, and a single space in between comma’s, with double quotes.
I’m not sure if spacing or double quotes were an issue, but when I made my network key with capitol letters then repaired secured, it started working.

I currently have 3 of these in my home from a previous Vivint install. I have successfully paired two of them with Home Assistant with no issues what-so-ever.

But the third one shakes fist at sky I cannot for the life of me get all of the entities to show up. It is missing the binary sensors for the unlock/lock wireless as well as manual unlock/lock binary sensors. With the two successful locks these sensors showed up immediately.

There are some different config values in the one not working:
Kwikset Not Working User Values1

Compared to the working ones:

Does this have to do with the Unsecure setting perhaps?

Another difference is this config value:
Kwikset Config Values

But I don’t see this as an issue.