Lamp doesn't turn on/off or dimable

Hello all,

I used one of my LSC LED E14 (Action, store in The Netherlands) to test with Home-Assistant.
This is the lamp: https://www.action.com/nl-nl/p/lsc-smart-connect-slimme-multicolor-ledlamp/

I flashed the lamp with tasmota using tuya-convert and after that I went to ESPHome, compiled the lamp config and flashed the bin file to the lamp.
The lamp is showing online in ESPHome (Home-Assistant integration) but I’m not able to control the lamp in Home-Assistant.

Am I doing something wrong?
Below is my config file for the lamp.

substitutions:
  devicename: lsc_bar_1
  upper_devicename: Bar 1

esphome:
  name: $devicename
  platform: ESP8266
  board: esp01_1m

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password
  domain: !secret wifi_domain
  fast_connect: true
  manual_ip:
    static_ip: 192.168.60.101
    gateway: 192.168.60.254
    subnet: 255.255.255.0
    dns1: 192.168.60.4
    dns2: 8.8.8.8

api:
logger:
ota:

binary_sensor:
  - platform: status
    name: "Bar 1 Status"

output:
  - platform: esp8266_pwm
    id: led
    pin:
      number: GPIO4
      inverted: true

light:
  - platform: monochromatic
    id: status_led
    name: "Bar 1 Lamp"
    output: led

switch:
  - platform: gpio
    id: relay
    pin: GPIO12
  - platform: template
    name: "Bar 1 Relay"
    optimistic: true
    id: relay_and_light
    turn_on_action:
      - switch.turn_on: relay
      - light.turn_on: status_led
    turn_off_action:
      - switch.turn_off: relay
      - light.turn_off: status_led

Can you control it via the web page
Also did you verify the pin out when you had tasmota on it.

Hello,

Thank you for your response!
Control it via the web page, do you mean the page when tasmota was flashed on the lamp?
I haven’t tested anything when tasmota was installed on the lamp, also didn’t verify the pin.

So you can control it via it web manager ?
So is it not appear in HA that the issue

I added below option to the ESPHome config for this lamp to enable the web server:

web_server
  port: 80

I can connect to the web portal but also not able to control the lamp from there.

Okay so where did you get the gpio info from

Found someone who also uses these lamps, thought I could take over his config.

that should be true

But it seems that it isn’t :frowning:
I re-flashed the lamp with tasmota and here is the config:

and does it work in tasmota
from that pic you have the pin out all wrong

Don’t really see anything to control the lamp (have to say I’m completely new to this).
I also don’t know what this config should be then.

https://templates.blakadder.com/lsc_smart_connect_candle.html

Thank you, now I got it to work with Tasmota!
Now I only have to add it to ESPHome and control it via Home-Assistant… :slight_smile:

image

Don’t know if esphome supports the SM2135.

1 Like

yeah i think no is the answer as well
you may have to leave it as tasmota and setup mqtt

But how do I add the lamp to HA then?

Mqtt
if you setup discovery on tasmota it should add it automatically
otherwise

If you have MQTT running, just issue setoption19 1 in the tasmota console. It will be added to HA without you doing anything.

Okay I installed the addon Mosquitto broker and configured it.
I ran the command setoption19 1 in the console but how can I verify it added correctly?
Don’t see the lamp in HA.

Do I still have to configure the lamp manually?

Check the integrations
You should see it there