Let's Encrypt options do not parse

I’m trying to setup the Let’s Encrypt add-on.

The options I used did not parse so I reset to default, but when I save that, the defaults do not parse either.

image

Bit lost where to go from here!

Uninstall the add-on
then Install it again

How do you intend for it to get you certificates if you don’t supply the domain name you want the certificate for and the email address to register it to?

Same issue.

When I do fill in my details, the options do not parse and give the same error. As the defaults do not parse either, there appears to be an issue.

I subsequently found this

In that issue it appears that the OP is trying to do this without a domain name, letsencrypt must have a domain name.

Can you put the details in, press save and in the event that you get an error post a screenshot with anything sensitive blanked out please?

Ensure you are putting your details in with “quotes” and be sure to maintain the commas as you edit.

This ^^^^^
In addition, the addon won’t let you save the settings and they will be in RED text if you enter invalid details. It will only save if it’s valid and in white text.

I’m asking a silly question
So do you already have a domain you want to use ?

It can easily be checked by anyone, just paste the example above in the docs

image

Yes I have a domain, hosted on Cloudflare DNS so the DNS challenge works (I use it for other subdomains) as I have done it using certbot directly.

Which they are not (as you can see).

Spot the missing comma

image

Ok… I don’t use this addon (as I use Caddy) Does it actually support Cloudflare? If you use Cloudflare, why don’t you just download and use the Cloudflare carts for your domain? I don’t know why you are using this addon at all? I am going to play around with cloudflare on a test instance I use soon…

@baz123

this works
well it accepts it at least so its a start
best bet would be to message Frenck

{
  "email": "[email protected]",
  "domains": "home-assistant.io",
  "challenge": "dns",
  "dns":[{
  "dnsprovider": "dns-cloudflare",
  "cloudflare_email": "[email protected]",
  "cloudflare_api_key": "31242lk3j4ljlfdwsjf0"
  }]
}

Thanks, I wondered if I had missed something in the options.

It is an issue on GitHub that @frenck has seen so I’ll see what happens.

I’ll try this as a starter and see if it works.

Thanks to all.

As it stands, the add-on will not start with the above config with valid credentials.

Note this is a Generic Linux install of HassIO on DietPi.

So found a config that works - not sure if a full restart changed something…

Obviously not my credentials :grinning:

{
  "email": "[email protected]",
  "domains": [
    "home-assistant.io"
  ],
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "challenge": "dns",
  "dns": {
    "provider": "dns-cloudflare",
    "cloudflare_email": "[email protected]",
    "cloudflare_api_key": "31242lk3j4ljlfdwsjf0"
  }
}

I think the config needs the certfile and keyfile entries, which are part of the default entry but not the sample config.

Cheers all.

Final question, I have start on boot enabled;

image

but it does not start. Should it?

image

As there is no datetime on the log, it is difficult to know whether it has started and stopped on the latest reboot!