Leviton Decora D26HD Dimmer - Sluggishness on Physical Button changes reaching HA Dashboard

I have a Leviton D26HD Dimmer (Decora WiFi integration here - I am not using Zwave, just wifi for this -) and it has worked seamlessly with HA right out of the box from day 1 - except for now. From HA I can control the switch seamlessly and the changes are immediate. However, physically turning the light on or off no longer was reflected in HA.

So I did the typical troubleshooting, rebooted the switch, makes no difference, then restarted HA, made no difference, rebooted the HA host, no difference, deleted the swtich form the “My Leviton” app and did a full factory reset of the switch, then re-added the switch to the My Leviton app, then restarted HA again. Everything works now except the manual turning on and off of the switch which was not reflected in HA at all before - is reflected in HA but only about 30 seconds after the switch is actually manually turned on or off. That used to be reflected immediately in HA. As a last resort I then rebooted my router. FYI, every device in my network including this Decora switch is assigned a static IP by my router, it is an enterprise class network in the home, the router is not wireless but is hardwired by Cat6 ethernet to several wireless access points throughout the home that are all set to use non-overlapping wifi channels. My internet up and down speeds are over 900mbs in each direction (one gig fiber service).

Has anyone run into this issue and resolved it in a satisfactory manner? It is weird that it doesn’t even show as an HA integration under settings (it never has - just always worked flawlessly). When the device was added, just like it was when I first got the switch, HA informed me there was a new device available - but only through the Apple Homekit integration which I do not use - I have no apple devices - which I do not need and ignore. I get the impression therefore that controlling the switch from HA in this manner is most likely a very direct internal network WiFi connection to the switch itself, but the reporting back to HA from the switch on manual physical changes to the switch most likely go from the switch to the Leviton Decora Servers over the internet, then back to HA from those same Leviton servers over the internet. If that is the case then the culprit is most likely a server latency issue on the Leviton side…

One last troubleshooting effort - the “My Leviton” app shows the physical switch going off about 10 seconds after is is manually switched off - same with manually turning it on. But is it still takes about 30 seconds or more to be reflcted in HA now. Note, I have changed all transitions to on or off to zero - (no 30 second fadeout or fadein when it is turned off or on - to make sure that is not a reson for the delay -)

Thoughts on how to resolve?

From what I can tell, that integration is a cloud based polling integration. There is no direct WIFI connection between HASS and the device. So it all goes through the cloud. Since it’s polling periodically sometimes you’ll get lucky and the switch state will be updated soon, other times you’ll need to wait for up to that polling period.

Bah humbug. Ok thanks… Reminds me of the old scenario where one digs and digs and digs and asks all the right pointed questions to try to resolve the issue, and gets answers that make perfect sense but that still do not resolve the end issue! The only real resolution is to replace the switch with one that can operate completely locally (preferably over Wifi, nothing with an extra hub needed). I guess I won’t buy any more of these dimmers. sigh.

Any idea for such a dimmer that can also integrate with HA?

Leviton says that the D26HD supports Matter.

All Matter devices support local control. It’s a requirement of the spec.

Updated firmware for the D26HD may be needed. Matter support for the D26HD is very new.
Thus I believe that the D26HD will integrate with HA and allow local control via Wi-Fi once the switch firmware is updated.

Where can I get more info on this? The app Leviton app says I have v1.5.0 of the firmware and that is the latest - so maybe it isn’t out yet? Or I need to also change my integration somehow?

I followed these steps to integrate my D26HD dimmer with Home Assistant running under Proxmox on a ZimaBoard:

  1. Add Matter integration to Home Assistant.

  2. Restart Home assistant.

  3. Follow these steps carefully. Don’t skip anything! https://decorasmartsupport.leviton.com/hc/en-us/articles/11638969410331-How-do-I-Update-my-Decora-Smart-Wi-Fi-2nd-Gen-Device-to-Support-Matter-

By doing these things, I was able to add the dimmer and control it as expected. It works reliably.

1 Like

Thank you very much for this @SophieO, I hope it’s not super buggy! Is it reliable for you?

Linking the switch with Home Assistant was troublesome. Once I got it linked, it has been reliable.

A couple more tries and rebooting the D26HD - and finally connected.