Light switch missing out of the blue

Hi to everybody.
I’m new to this forum, so please forgive me if I will do something wrong.
I tried doing searches in the forum, doing google search and reading documentation… NOTHING!

Here is the situation:

I have an installation in which light are attached to outleet switch.
Switch is from Meross. Light is dumb.

I configured in the configuration.yaml two light switches using

  # Converte gli switch in luci
  - platform: switch
    name: Lampadario1
    entity_id: switch.lampadario1

  - platform: switch
    name: Luce Marito
    entity_id: switch.luce_marito_outlet

The first one is perfectly working, the second one is missing. I do not find it in the developer tools.
Both underlying switches are perfectly working.

Moreover, from couple of days 3 switches that were PERFECTLY working (already configured in the same way and used many times) stopped responding. FYI, i did NOT update anything in the installation, they are still there, but reported as unresponsive by Home Assistant.

Already tried restarting HA several time, didn’t fix the issue.
Also power cycle to the haardware where HA is installed didn’t fix the issue.

Any advice?

Thanks in advance,