Local DuckDNS Access Arris BGW210-700 NAT loopback

I am using an Arris BGW210-700 modem/router from AT&T. I have setup DuckDNS correctly for my HA instance and can access it without any issues when I am outside of the network my HA is running on.

However, when I am on my local network, I can only connect through the local IP address, 192.168.1.x. If I try to browse to HA via the DuckDNS url, I get a page returned with the HA logo and the message “Unable to connect to Home Assistant.”

If I look at the developer tools console, I see this error message “https://mydomain.duckdns.org:8123/auth/token 400 (Bad Request)”.

My understanding is that this is an NAT loopback issue but that the Arris BGW210-700 doesn’t support that. I was wondering if anyone out there had experienced something like this or had any ideas on how I can work around this? The biggest issue being that I can’t access HA via the iOS app when I’m at home without first turning Wi-Fi off.

Ditto, same problem here. Looking forward to a workaround. Will post if I discover a solution.

I’m running in to the same issue as well, except with Cloudflare instead of DuckDNS. Also due to AT&T’s lack of NAT loopback. Were either of you able to find a workaround? I’ve been at it for a couple days with no luck.

After a lot of research, I think the only way to really address this problem is to get a separate router and put it between your network and the ATT gateway router. The reason being that ATT’s router is so limited in functionality, it doesn’t offer the tools necessary to accomplish this.

First, as you noted, there’s no NAT loopback. Second, it doesn’t allow you to change the router’s DNS server, which prevents setting up a split brain DNS.

So short of using a new ISP or getting a separate router, I’m not sure this can be accomplished with just ATT’s equipment.

I did finally find a solution to this. You’ll need to install the AdGuard Home add-on and use it to handle DNS lookups for devices that you want to access HA on.

For each device, you need to edit what IPs it uses for the DNS and change them to be the ones that AdGuard is listening on. Once you’ve made that change, you can follow the relevant directions for Split Brain DNS on the Companion App Networking page.

It’s unfortunate that there isn’t a more seamless solution solely because ATT’s equipment is so limited, but once I found this solution it was pretty easy to implement. The obvious downside would be that if there’s a time HA was down or restarting, I think there would be problems with any altered devices connecting to the Internet.

1 Like

I am going through the same issue with the ATT router. I am very lost about how you set up AdGuard to work and getting it to work. Seems like I can’t set a custom DNS server. Any advice?

Any repsonse or detailed instructions on how to setup AdGuard for this?

Hi.
We are an IT provider and have the same issue in Mutiple customers except one where even when pinging the DDNS host of the NAS from the LAN we get the WAN IP as the reply, we can access the NAS perfectly from the LAN using the https://DDNSname.provider
We are trying to compare setting by setting to understand why it does work on one and not in many.
Will post findings …

Well … we activated remote access on the BGW that is working but is not taken the remote access request. Will have to wait until we are on-prem.