Local Tuya Connection Authentication Failure

Hello,

I am moving from HE to HA. HE has a local Tuya integration so I am familiar with getting the backend stuff setup to make this work but I’m having some trouble. It’s definitely detecting the devices but then I hit a wall.
Steps taken:
I am on HA OS

  • Removed the cloud Tuya from HA; restart
  • Downloaded Local Tuya from HACS; restart
  • Integrations>local Tuya
  • It detects my devices. I confirm their Device ID’s are correct and select one>submit
  • Fill out the basic information. Grab the Access Secret/Client Secret: from Tuya>enter it in the local key field, confirm the device ID/IP are correct>submit>fails authentication
  • I have confirmed that the tuya cloud app is linked to my Tuya/smartlife app (just like I had to do with the HE integration. I know it says zero devices. My hubitat integration says the same thing and this still works.
  • I’ve tried this using the access secret/client secret of BOTH my HE and HA Tuya cloud apps and I get a failure each time. In my desperation, I also tried every combination of the access ID and client secret from BOTH my tuya cloud apps and I received the same results. But I know it’s supposed to be the super long one called:
    2022-01-03 11_43_39-Greenshot
  • I know that running tuya app concurrently can cause issues. It was force stopped long before any of this started.

I have tried this multiple times and I’m so close. It seems like I’m missing something incredibly trivial. It DEFINITELY sees all my devices with the correct IPs. I just can’t authenticate.

“client secret” is not the same as “local key”… therefore authentication failure.

You can get local keys with rooted android phone and an older TuyaSmart app like this:

You can also get keys from iot.tuya if you go to API Explorer and then select “Get device information”, put in your device id and click Submit… in the response you will see the local key, which is different for every device. It also changes, if you remove the device from tuya app or iot and re-add it.

Edit: Beware to select the correct Data Center (the one you deal with in your country - default is China) before “Submit”, orelse you will get an error.

1 Like

local key

Hello and thank you for the hints. I never would’ve known a local key was located elsewhere.

I have found my way to that location to try to get the local key but I’m receiving an error?

I am getting this error on all the device ID’s. I am copying the device ID’s out of HA and into iot.tuya. I tried this on several devices and I’m receiving the same message.

I tried to add devices using the IOT Management app but was unsuccessful. I didn’t see any mention of those steps so I’m assuming I’m not supposed to use that.

I verified that my connection server and searches have all been in eastern america
I’m not sure that this matters because it never mattered in my HE Tuya integration but my smart life app link says zero devices. It has always said this:

1 Like

I have 8 Costco FEIT Wifi LED bulbs. I was able to add 7 of them to Local Tuya, but the 8th is giving me the Connection Authentication Failure error. I’ve tried several times. I’m stumped. Any suggestions to fix this?

Yep, this confirms I’m doing everything right. I reconfigured the project (because you cannot delete projects). When linking to the smart life app, I scan, it logs in and links the app but it says zero devices. He breezes right on by that because it should be working.

He has the same screen as me with 16 devices where I have the same screen it says zero. I unlinked it and re-linked it twice. I also moved a device from the smart life app to the tuya app and I received the same problem. Because my tuya and smart life apps had the same credentials I created ANOTHER tuya app, slapped a fan in it, linked it up and it did the same thing. zero devices:

I put in a ticket because the app name also shows in another language unlike the tutorials. I have very old accounts before any of this was available and I’m thinking that something is twisted with the account management on their end. The fact that it has always said zero is very curious (even with my HE integration).

I was informed in another thread that there’s been problems with their iot platform today. I’ll wait for a response from them. Thank you for all the valuable information, I wouldn’t have made it this far without that much.

Hey @Sergeantpup - Did you make any progress with this? I get exactly the same outcome when trying to register my app/devices.

Sure did. When Tuya contacted me, they told me to switch servers. I know all the tutorials said to be careful of that fact but it was counterintuitive because I am in Atlanta and I was connecting to the Eastern Americas server. They told me to switch to the Western Americas server and as soon as I did, everything started flowing.

Was it just for the project? I was using Western America, and have just tried Eastern America, but neither seem to work.

I went back and double checked my settings. It looks like the project is configured for both (because Tuya’s EXACT verbiage to me was “ADD the western server” they didn’t say replace).

but then on the device page, select the western server (this is what made the data flow)