Locked out and the "I'm Locked Out" post is no help

This is on one of the Ameridroid/ODROID XU4Q HA bundles. The initial onboarding (thanks to my over-sensitive trackpad double-clicking) got short-circuited, and there appears to be a user that got installed, but it’s not the info I entered. None of the info in the “I’m Locked Out” post seems to apply to my situation. I can go in with a file viewer and see the configuration.yaml file (which is not located where that post says it should be, as there is no config or .config directory I can find. Did the file/directory structure change with HAOSS 10?), and it’s almost empty with nothing about a user or authentication in it.

If I just delete that file and reboot the XU4, will I get a fresh onboard?

Rather than some random post on the forum, try the documentation:

As I mentioned in the subject line of my message, that “documentation” is of no help.

The documentation is not “a post”.

Delete the specified contents of your .storagedirectory (it is hidden). Then restart to begin onboarding again, just like it says to do in the documentation. https://www.home-assistant.io/docs/locked_out/#start-a-new-onboarding-process

Zero help. Ended up reflashing the eMMC and starting from scratch.

I’ve been locked out due to a bug in HA. Ended up resorting to starting a new onboarding process, however I can’t get it to work.

I have stopped HA and done the following:

  • auth - Renamed to auth.old
  • auth_provider.homeassistant - Renamed to auth_provider.homeassistant.old
  • onboarding - Renamed to onboarding.old
  • hassio - Could not find any such file. Is this normal?
  • cloud - Could not find any such file. Is this normal? I don’t use Nabu Casa.

When I then start HA again, I’m not taken to the onboarding process, but to the normal login screen.
I notice that auth is recreated when I start HA, but this does not happen with onboarding or auth_provider.homeassistant

I run in docker, and I notice that in parallel to the ./storage folder, I have a folder called .cloud, but it’s empty. I also notice that in parallel to ./storage I have the .homeassistant folder wherein I find another auth file. In desperation, I tried renaming it to auth.old and restarting, but it made no difference and it’s not recreated on boot indicating it’s not the right auth file.

I’m stuck and have been so for a few months (I run 4 HA instances, and this is the only one I have this problem with)

Thankful for your help!