Logbook, History, no-show , killing Hassio

Hi,

To get back to an older issue ive been having, but didnt work-out yet, I was wondering if the Logbook and History problems have been solved, and if yes, how…

whenever I click logbook or history, it takes forever to show up exactly nothing. Most of the time the system gets disconnected, I suspect some loop or so, cause the only thing I can do is hard-boot the Pi, by pulling the adapter cord .


Have following settings:

  logbook:
    ## https://home-assistant.io/components/logbook/

    include:
      domains:
        - sensor
        - switch
        - media_player
        - light
        - automation
      entities:
        - device_tracker.phone1
        - device_tracker.telefoon
        - device_tracker.phone3
        - device_tracker.phone4
    exclude:
      entities:
        - automation.count_warnings

  history:
    include:
      domains:
        - sensor
        - switch
        - media_player
        - light
      entities:
        - device_tracker.phone1
        - device_tracker.telefoon
        - device_tracker.phone3
        - device_tracker.phone4

    exclude:
      entities:
        - automation.count_warnings

using MariaDB (since the regular home-assistant.db kept growing, and wouldn’t be purged, no matter what) and InfluxDB

recorder:
    db_url: !secret db_url

    purge_interval: 2
    purge_keep_days: 3
    include:
      domains:
        - sensor
        - switch
    #    - media_player
    #    - light
        - automation
        - script
        - input_boolean
        - input_select
        - input_number
      entities:
        - device_tracker.phone1
        - device_tracker.telefoon
        - device_tracker.phone3
        - device_tracker.phone4

    exclude:
      domains:
        - weblink
        - updater
      entities:
        - sun.sun # Don't record sun data
        - sensor.last_boot # Comes from 'systemmonitor' sensor platform
        - sensor.date
        - automation.count_warnings

I’m currently having this problem in 0.84.6. Click on Log Book and the entire raspberry pi hassio locks up, have to cycle power to get it back.

I’m on 0.86.1 and am having the same issue.
I am also running MariaDB on a Synology NAS. All connections are via 1GB Ethernet.

The Logbooks takes ages to load and when I click on history the systems just stops working.