Logger not logging

Running on a Pi, installed from image. I can’t get anything to log at all. I have updated my configuration.yaml:

Our command line:
$ ha help

➜  ~ cd config

➜  config pwd

➜  config cat configuration.yaml

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
# Example configuration.yaml entry
  default: debug

➜  config ls /var/log -la
total 8
drwxr-xr-x    2 root     root          4096 Oct 21 05:25 .
drwxr-xr-x    1 root     root          4096 Nov 24 05:46 ..
➜  config

As you can see, not a single log file exists in var/log. I have the logger setting enabled, so I am puzzled. Any ideas?

Why are you looking in /var/log?

The homeassistant log is in your config directory, same place it’s always been.

OK, so I was looking in var/log b/c that’s where it is on every other *nix platform I’ve ever used. No worries. I do see the home-assistant.log file.

But I have another problem then. I installed the log viewer add-on and it is blank. No logs at all. I have started the add-on, and no errors reported in the log page for the log viewer add-on. But the log viewer page does not show any logs at all. I suppose that is a different question from the original, but I wonder if it has an easy answer?

I have no idea about the log viewer addon, but you can view your homeassistant logs in the interface under configuration > logs, or in supervisor > system > log provider