"Login Attempt Failed" (but hasn't actually)

ios
Tags: #<Tag:0x00007f47fbb04e70>

#1

I’ve just installed the iOS app and configured my fresh hassbian install. It seems to work ok, but every time I load it I get a panel added to my Home Assistant complaining that "Login attempt or request with invalid authentication from " but it has logged me in and seems to work fine. If I choose “Log out” from the Home Assistant menu, then refresh the app, it stops doing it for a while…

I am running Home Assistant 0.42.4 with a Lets Encrypt certificate.

Any ideas how to stop it complaining?


#2

I have the exact same issue. When I login through the iOS app I get the same “Login attempt failed” message every time, even though the app is logged in and gains access to my HA successfully.
I have IP ban activated and after the set limit my phone’s IP gets banned. So there really is a faulty login happening in the background, one for each successful login.


#3

I’m having the exact same issue! Has anyone worked out a fix yet?

I’m also finding location updates from the app unreliable. I’m wondering if this is related.


#4

I reinstalled the app and also made sure HA was up to date - seems to have fixed it I think!


#5

Cool I’ll try reinstalling! Thanks.


#6

Same here, reinstalling didn’t help :frowning:


#7

Reinstalling the app on my iPhone resolved this issue for me.

Issue began after changing the password in the http config, and after updating to the correct password in the app. I was able to log in, but would receive the error message mentioned above. Uninstalling the app, restarting the phone, reinstalling from the app store, then re-entering the correct credentials in the app resolved the issue. Thanks!


#8

Hi

I had the same issue and what I needed to do is stop the appdaemon and restart it. For now the issue has gone away, so I thought I share it in case someone is still struggling.


#9

Wanted to check in to let people know that I’m having the same issue as well. It used to give me the reverse proxy IP address in the error message, but now I set the “use_x_forwarded_for” option to the http component and the error still happens but populates it with the correct IP address of my phone. I think it’s either a problem with the iOS app (anyone using an android app and it’s happening?) or somehow using a reverse proxy is causing it (I doubt this).


#10

I’ve not got this issue, but the app keeps logging out and loosing the server credentials


#11

Same problem here … I’ve gotten fed up of filling it in all the time now I’ve started to stop using it.


#12

Same issue, running into this each and every time using the iOS App. Also it seems to not store the setting / home assistant IP configuration. If I ask to save it errors with wrong password.


#13

Have you logging in with api password and ip (not hassio:8123)
I fixed my just by adding ip instead of hassio:8123


#14

un-installed, re-installed, did it again, still no worky. :frowning:
what password does the iOS app want?
it’s not the API password in configuration.yaml
it can’t be a user password, because there’s no place to put a username.
:frowning: :frowning: :frowning:


#15

it is the legacy_api password.
You could/should get the new beta app for iOS and you can then use the new HA auth.


#16

I did, and it connects successfully. Thank you, @DavidFW1960. :slight_smile:


#17

Where can I get the new beta app? I don’t find in the Apple Store, only the regular version that still has the login attempt failed issue.


#18

Look in the iOS section… there are a few links in threads there for the beta app.


#19

Which setting are we to use in the beta app to login? HA is updated to 0.83.3 and the app is up to date.


#20

Enter the URL and leave the advanced settings off. Click Validate & Save and you will be prompted to logon using the standard HA auth screen… even 2FA if you have that running. Then tap done and you will be logged in and will see an option to save the login on bottom right corner.

Most important - don’t enable the advanced options…