Login attempt failed from iOS device

Same here.
@PingSpike Your workaround seems a good start, have you figured out how to detect the notification ?

1 Like

No, sorry @JohannCR I’m still using this bodge / messy hack :confused:

Would love to hear if anyone else has a more elegant solution to this problem.

A new update of the HA iOS APP is available. There it is described that the update fixes this error. I have just installed it and hope that everything works out now.

1 Like

I’ve updated the app on my iPhone and iPad today.

This issue still persists :pensive:

Same here :see_no_evil:

1 Like

I am also seeing this issue and I am running the very latest HA.

I am almost 100% that at least some of these false positives are caused by how the IOS application handles camera components. Nearly every one of my HA screens has a camera on it except for 1. If I leave the IOS app on that screen, I don’t get the notificiations when I re-launch it. If it is sitting on any other page which has a camera, when I re-launch it, I get the notifications every now and again.

Using an automation to clear the persistent notifications you will never know if you have someone trying to hack into your HA instance.

1 Like

I think it’s in the proxymanager with your forward ip’s but i don’t how to fix it…

Same problem here.
Only on iOS, Android works fine.

If you’re not running the beta version of iOS app from TestFlight try that. There was a bug with auth a while back…

Dear David,

i have tried but same problem.
What helps (as far as i can see) is moving RTP camera stream from main tab to some rarealy used tab.
Looks like it has something to do with RTSP stream of my camera.

Do you use cloudflare in your setup?

No Cloudflare here. I do use an SSL proxy to front end external connections on 443 and push them through to 8123.

Same here! Don’t think it has to do with camera feeds. I’ve had the messages before having the camera feeds.

I run the latest HA thru duckdns and I indeed think it is a glitch somewhere

This seems to be an iOS issue, app auth token expiring or something similar. I only run HA internal, and get login failed daily from the only iOS device I have on the network. It is the only device that reports invalid logins – happens if the app is in the background for a while though I don’t know the exact timing. The app does not report errors or a login failure so it happily reauthenticates fine, but I think it is sending an expired token first triggering the HA alert.

1 Like

Have you tried toggling background app refresh? :thinking:

I’m not too much up on Apple tech, but more than willing to try anything at this point. I will search on that option to see what I can find. It’s not really a critical issue, just a bit of an annoyance for me.

*edit: Background refresh for the Home Assistant app was on, I’ve toggled it off. time will tell if I get another message though I don’t expect much from my testing. The alert typically happens when the ipad comes out of sleep, or my wife switches back to the app from another she is using.

Same issue here as well. Only my wife’s iPhone is causing these invalid logins. My iPhone is working fine. We both use the same HA instance with identical views and cards.

Updating this thread, changing background refresh had no effect. I still get an invalid login attempt at least once a day from the ipad.

I’ve reinstalled the app on my wife’s ipad, created a new account, setup a new instance of HA and just about everything in-between and still get the alert once a day at least. Same as you we use the same dashboards – unfortunately her iPad is the only iOS device we have to test with, interesting to know only one of your IOS devices is creating the notification.