Login failed to Node-RED


#1

Hello, been using Node-RED for a while flawless then all of a sudden I can’t login anymore! Super annoying, I’ve tried to change the password and user name but it keep saying “Login failed”. The automations work

Log:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 

-----------------------------------------------------------
 Hass.io Add-on: Node-RED v1.0.0

 Flow-based programming for the Internet of Things

 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
-----------------------------------------------------------
 amd64 / Ubuntu 18.04.1 LTS / HA 0.81.1 / SU 138 / stable
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 

INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
INFO: Password is NOT in the Have I Been Pwned database! Nice!
INFO: Password is NOT in the Have I Been Pwned database! Nice!
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 20-config.sh: executing... 
[cont-init.d] 20-config.sh: exited 0.
[cont-init.d] 80-system-packages.sh: executing... 
[cont-init.d] 80-system-packages.sh: exited 0.
[cont-init.d] 81-npm-packages.sh: executing... 
[cont-init.d] 81-npm-packages.sh: exited 0.
[cont-init.d] 82-user-scripts.sh: executing... 
[cont-init.d] 82-user-scripts.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

> [email protected] start /opt
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"

30 Oct 21:15:57 - [info] 

Welcome to Node-RED
===================

30 Oct 21:15:57 - [info] Node-RED version: v0.19.4
30 Oct 21:15:57 - [info] Node.js  version: v8.12.0
30 Oct 21:15:57 - [info] Linux 4.15.0-36-generic x64 LE
30 Oct 21:15:58 - [info] Loading palette nodes
30 Oct 21:16:00 - [info] Settings file  : /etc/node-red/config.js
30 Oct 21:16:00 - [info] Context store  : 'default' [module=memory]
30 Oct 21:16:00 - [info] User directory : /config/node-red/
30 Oct 21:16:00 - [warn] Projects disabled : editorTheme.projects.enabled=false
30 Oct 21:16:00 - [info] Flows file     : /config/node-red/flows.json
30 Oct 21:16:01 - [info] Server now running at http://127.0.0.1:1880/
30 Oct 21:16:01 - [info] Starting flows
30 Oct 21:16:02 - [info] Started flows
30 Oct 21:16:02 - [warn] [api-call-service:Notify iPad] Error calling service, home assistant api error
30 Oct 21:16:02 - [error] [api-call-service:Notify iPad] Error calling service, home assistant api error
30 Oct 21:16:02 - [warn] [api-call-service:Notify iPhone] Error calling service, home assistant api error
30 Oct 21:16:02 - [error] [api-call-service:Notify iPhone] Error calling service, home assistant api error
30 Oct 21:16:02 - [info] [server:Home Assistant] WebSocket Connected to http://hassio/homeassistant
30 Oct 21:17:06 - HA Auth - Failed to authenticate: filip
30 Oct 21:17:07 - HA Auth - Failed to authenticate: filip
30 Oct 21:17:08 - HA Auth - Failed to authenticate: filip
30 Oct 21:17:09 - HA Auth - Failed to authenticate: filip
30 Oct 21:18:13 - HA Auth - Failed to authenticate: filip

Settings:

{
  "log_level": "info",
  "credential_secret": "secret token",
  "http_node": {
    "username": "filip",
    "password": "supersecretpassword"
  },
  "http_static": {
    "username": "filip",
    "password": "supersecretpassword"
  },
  "port": 1880,
  "ssl": false,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "require_ssl": true,
  "system_packages": [],
  "npm_packages": [],
  "init_commands": []
}

Any ideas?


#2

Hate to say it, but +1. I am trying to login with credentials listed from Node-Red Addin.

30 Oct 21:05:46 - [info] Started flows
30 Oct 21:05:46 - [error] [server:Home Assistant] Error: Invalid access token or password.
30 Oct 21:05:46 - [error] [server:Home Assistant] Error: Invalid access token or password.
30 Oct 21:25:09 - HA Auth - Failed to authenticate: b2nodered
30 Oct 21:25:43 - HA Auth - Failed to authenticate: b2nodered

#3

At least I’m not alone :slight_smile:


#4

I’ve updated to version 1.0 and now I cannot log in either.


#5

Seems like there is some kind of problem there. I’m downgrading again for now.


#6

Release 1.0 has breaking changes


#7

Hmm. Now I did not do anything but it just started to work.


#8

+1 Same here


#9

I am an idiot. I have acctually read the realese notes.


#10

It’s also broken the login for me.

Is there a way to roll back to a previous version on hass.io?


#11

I restored from a previous snapshot and then updated again and it worked.


#12

Do you mean you restored the whole node red folder from a previous snapshot?


#13

Guys, just use HASSIO login and password, rather than the ones you have in node-red config.


#14

Amazing. All working. Thank you.


#15

I tried using Hassio login/password and that doesn’t work either. Any other suggestions?

EDIT: Nevermind, it’s working now.

Thanks


#16

Seems like it was just me being stupid and not read the release notes thoroughly enough. I missed from the beginning that the add-on was updated. Anyhow for me at least its working as supposed with the HA credentials.


#17

For me it does not work. Or Node-red works and is connected to home assistant. But I cannot login to the web ui. Some people write about a change inte the release notes, but I have been unable to resolve the problem.

Can you help me?


#18

Which HA version do you run?
You need to be at least on Home Assistant version 0.8x.x to be able to use your HA Authentication credentials in the v1.0.0 release of this add-on.

(I experienced the same behavior and raised an issue yesterday to include that in the documentation as well)


#19

Any more details?

I had another issue after upgrade because I used to run NR over HTTP, and HA over HTTPS. Turned out that Node Red was trying to authenticate me with HA over HTTP, and obviously connection was constantly refused. So maybe check that out…


#20

It really helps to read the documentation.
I didn’t know that I upgraded to the newest version.

But TL;DR: Use your HomeAssistant user authentication (to the Node-Red Web UI)

Worked for me