Login issues with correct user name and password

Hello, I have been using Hass.io for about 12 months and have learned loads considering I knew less than zero going in. I have an odd issue that is doing me head in. I had to set up a new user because of it so here we go…My main user name is XXXXX and password is xxxxxxxxxxxxxxxx. I use it on 4 devices, no issues, never have to log in as they are all local devices but my instance does have exposure over the web and this works fine. Issue is that when I try to log into my main username from another account, it says password or username is not correct. But it is. I am always logged into the username so I can see the proper format for capitalization, its very simple. I know the password is correct because I can change it and have done. Yet. any new device says one of them is wrong. I have tried Admin, admin, Administrator, administrator, Xxxx, xxxx, etc… for user names. As I say, I ended up creating a new user but would like to delete that user and get it functioning as it should. Been an issue for a few months now. Any suggestions please?

You never have to log in because you saved a refresh token (see your user profile), not because it is local access.

I don’t understand what this means. What do you mean by ‘from another account’?

If you log in using an account with administrator privileges you can delete users in the configuration / user menu.

I see I butchered the English language a bit, I’ll try to clarify, thanks for replying.

I understand the refresh token bit, were good on that.

When I typed “…I try to log into my main username from another account” I meant to type from another device or browser

I understand about deleting the made up username, I can only do that once I know I can use my credentials from other devices. Again I know the credentials are correct as I can see the username clearly and can change the password, delete and add users, etc,…

I feel it has something to do with the access tokens but can see they are all valid and are working. Is there a user limit on amount that can be logged in at once? Its just seems so odd and I am sure it will be something very simple.

Ok, so using credentials that are known to work on other devices you are unable to log in on a new device.

Do you use ip ban?

If there is I suspect it would be huge.

Yes, I do use IP ban …threshold is 4 attempts…I do not see anywhere in the directories where there might be a black list.

I have a feeling it has to do with this:

I do not have anything related to this in my config.yaml

Are you sure the username that you used is the same as the name of the user that you can see?

those are different things. When you set up a new user it asks for the “Name” and a “username”.


the name that you see is the “name” field. the way you log in is with the “username” field.

Any guesses what I might have used for a username then? lol.

I had tried admin and all variations of it, is there a default username? I had tried hass.io, Hass.io, hassio, Hassio, etc… I honestly can not think of anything I would have used that I can not remember now, but appears to be the case somehow, lmao. I also tried a blank field.

Now that I think of it, thats all it can be though…smh, thanks for your time!

so dumb…got it figured out…gonna add it to my dashlane passwords list, although it was the username that was wrong lol

1 Like

I have the same issue. i already made my own topic but no response so far.

I am 100% sure i have the right username and password. And i just can’t log in with these credentials.
i am still logged in on the IOS app, and i can see the username i use to log in. I even changed the password several times via the iOS app just to be sure i have the right password. But still if i want to log in on my desktop it says i have the wrong username/password.

sorry not much help, I am OP, for me it was using wrong username (field), it is different than the name (field)

Ok, well i think that is the same issue for me. I just created a new user, and i had to fill in a name and username. I assume that i used a different username then my account name.
Where can i find the users username. because when i go to users. i can only see the names but not the usernames.

Ok, i found it. in the file directory “root/config/.storage/” there is an file called “auth”.
There you can find your username in plain text. i am successfully logged in again :slight_smile:


on the main console screen of the device
you can type auth reset --username “usersname” --password “newpassword”

Hi all, I 'm new here and my first speed bump was the “Name” vs “username” nonsense… I think we can all be clear that that should be removed and only stick to username… or make it clearer.

1 Like

Just want to add that you wont be able to login if your user has a dash (-) in their name. I had created the same user multiple times “name-name” and once I modified the username to “namename” I could finally login. This should get fixed. What a waste of time!