Login to HA through Google Home - Looping

Hi, I created the test app in Google Assistant (GA) through Actions and I can see the [test] your app in the settings section. I’ve followed instructions here. I have DuckDNS set up as SSL. When I go to the test app it gives me the HASS login page. When I enter the user name and password and click Next, I am directed to the same page, like a loop. It never ends. I am sure the Username and Passwords are right. Any help is appreciated.
Attaching the account linking screen!
Thanks in advance!

are you forwarding 443 to 8123 8123 in your router? If you are, don’t specify 8123 to Google

I see a notification in HA saying "Login attempt or request with invalid authentication from 7x.xxx.xx…

Thanks, David. Yes. I am forwarding 443 and 8123 both to 8123. So, are you saying I should remove: 8123 part from all instances where a port included in the guide?

well how do you normally access HA when you are not on your WLAN? Do you specify 8123 there? If not then you shouldn’t specify to Google. I don’t have a port included in my url’s

Also under actions there is a url as well… can you post the actual URL’s (without the domain obviously) as these are truncated in your screenshot above…

Yes. I do not specify the ports. Just the direct DuckDNS address. I’ve removed all the ports in action and auth and token sections. I’ve restarted my test app. But I am still getting the loop. Also, I am seeing “Login in to Home Assistant Local” which seems I am still seeing it through ports.

The addresses were

https://xxx.duckdns.org:8123/auth/authorize
https://xxx.duckdns.org:8123/auth/token

and in Action
https://xxx.duckdns.org:8123/api/google_assistant

I’ve deleted all the “:8123” part from the links above and trying. How do I completely reset the test app?

And you have enabled testing for your app? Without the :8123 those URL’s are good.

I have previously enabled the app. Now after changing the the URLs, I’ve re-enabled the test app. Draft Snapshot time of the test app is after the change. But I am still getting the loop!

does the home assistant log show anything? or the google log (on the simulator screen errors…?)

The HA log show an invalid login attempt corresponding to the time when I had ports in the test app. Nothing with a timestamp corresponding to the changes. Also, app errors screen in the simulator is empty!
I am still seeing “Changes pending” in the account linking page. Not sure how to get rid of it!
See the screen shot.

Mine says changes pending too until I scroll back to the top.
Dumb question… the google account is the same on Google Assistant and in the actions console? (I guess it has to be otherwise you couldn’t attempt to link)

Sorry but that all looks right to me…

You don’t have IP_bans by any chance? My GA got locked out once o twice a while back…
And you are using the new auth obviously?

No question is dumb because I do those all the time :smiley: Yes, checked it. Same account.

No I don’t have IP_Bans on router. I don’t have IP bans on the HA Config and not sure if there is anything like that. I have IP bans on configurator settings but I don’t think it has a effect here.

Also, if I enter the password wrong when I try to login to HA through test app, I see invalid login attempt in the HA log. But nothing when I enter the username and password right. So, I think the test app is getting in to the HA.
I still think it is port forwarding issue. Following are my port forwardings. Anything that stands out?


Thanks again for all the help!

I would remove 80 to 8123! That might be an issue - unlikely… but that is just making your HA insecure… Why do you have that? Assume you have LetsEncrypt? If you are using the duckdns addon, it does TLS validation otherwise 80-80 for LetsEncrypt… but 80-8123 doesn’t make sense

Yes. That resolved it. It IS the issue. Thank you very much.

1 Like

Nice. So glad we got there.

1 Like

I love you guys!!

This is my first message in this forum.

I have been trying to connect my Google Assistant to HA and, when i wrote my username and password, it returns an error and can’t log in.

I had port forwarding:

80 to 80
443 to 8123

Watching @manjulapra configuration, i saw port forwarding:

443 to 8123, 80 to 8123 and 8123 to 8123

@DavidFW1960 told him to remove the 80 port forward, so I removed mine and added the 8123 to 8123 port forward, and PERFECT!!

Thanks a lot!!!

2 Likes