Logitech Harmony removes local API


#101

Second that. Great work Homeassistant, some of the other HA communities out there are still wondering what is going on! :smiley:


#102

Someone on the home assistant team should get in contact with the register (https://www.theregister.co.uk) - I’m sure they’d be interested in a story like this… It would help pile the pressure on Logitech to give a proper solution.


#103

They are developer friendly and their product has stunning build quality. I own three. But it is still an evolving product and their software updates are months and months delayed with long gaps between releases.

I also feel it needs just a few more hard buttons as it does not offer pick it up and action usage.

Both Homey and openHAB have really competent support for Neeo. Here’s hoping for something equally viable here.


#104

I think you are right, we are fairly safe for now. The title of this blog actually misrepresents the situation. The local API was not really removed, it was replaced with a more modern version (websocket). The new interface works at least as well. We were just caught by surprise because Logitech does not announce changes to this unofficial interface.

I don’t see Logitech removing the local connection, waiting several seconds for the volume to change via the cloud would be unacceptable. They might try to protect it with encryption etc. but nothing of that is present in the current websocket interface and it would take quite a while to roll out.


#105

I dont think the cloud APIs don’t expose the same capabilities. You know how limited the Google Home and Alexa integrations are? That’s because of the Cloud API they are using.


#106

Good point, I think they’ll need a local API in one form or another indefinitely. Here’s hoping it lasts, at least until NEEO is up-to-snuff in HA


#107

Great article about it:


#108

Nice to see a sensible, sticking to the real facts post rather than all this anti Logitech garbage others seem intent on spouting.


#109

I have just upgraded to the latest HA hot fix release, but both of my Harmony hugs still not working… They both are upgraded to latest firmware.

Is there anything else I need to do in the configuration file to make it work?

Thank you guys so much for quick fix! Just need some docs on how to make it work again.


#110

Same, I updated to 0.84.4 but get this in the logs

2018-12-20 13:22:47 ERROR (MainThread) [homeassistant.components.remote] Error while setting up platform harmony
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 128, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/local/lib/python3.6/asyncio/tasks.py", line 358, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/remote/harmony.py", line 106, in async_setup_platform
    name, address, port, activity, harmony_conf_file, delay_secs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/remote/harmony.py", line 155, in __init__
    self._client = harmony_client.HarmonyClient(host)
TypeError: __init__() takes 1 positional argument but 2 were given

#111

I get the same thing in my logs as well, and just the usual yellow banners in Lovelace where the hub commands should be.


#113

You guys using docker? Seems a hotfix 84.5 out


#114

haas.io (docker based, but I don’t see 0.84.5 for haas.io yet)


#115

I got 0.84.5 hass.io with my generic Linux install on a NUC 10 or so hours ago… I wonder what the delay is for the Pi?

Have you tried updating via ssh?


#116

Please file GitHub issues for the problems that you find with the updated integration.


#117

Are you saying that this removal was actually announced at some point?


#118

Anyone have a feel for when 0.84.4+ will be rolled out onto the Raspberry Pi versions for Hass.io? Reloading the supervisor or updating via SSH is still only getting 0.84.3, which is what’s reported for all architectures at https://s3.amazonaws.com/hassio-version/stable.json or the beta channel. Thanks


#119

Did you try forcing 0.84.5?

hassio ha update -o version=0.84.5

The json file and version sensor only show 0.84.3 for me too but I manually updated via the above command line 10+ hours ago…


#120

That fixed it. I was missing the -o flag.


#121

I have forwarded this to the big german techsite heise.de this morning. 2hrs later there is an article :slight_smile:
I really don’t get why big companies don’t embrace the communities that enrich their product.