Looking for help with tts and Google Home with DuckDNS, AdGuard and WireGuard

I need some help with getting my Google Home device working with/from Home Assistant.
I searched the community fora and there are lots of people with problems and solutions for this.
But unfortunately non are applicable to my situation and none are giving me hints where to search for the solution.

My Home Assistant is a docker installation on RPi4/ssd. I am using DuckDNS to access my system from the Internet; but I am using port 44001. Further I am using AdGuard and WireGuard.
So far, this configuration is working OK.
Btw, i made the correspondent port forwarding changes in my router.

My http config is this:

base_url: !secret ha_base_url
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem
ip_ban_enabled: true
login_attempts_threshold: 5

And in secret.yaml I have:

ha_base_url: https://<my-name>.duckdns.org
external_url: https://<my-name>.duckdns.org:44001
internal_url: https://192.168.178.222:8123

Also I installed Nginx Proxy Manager with MariaDB, but Nginx Proxy Manager is NOT running; I was looking at this for a possible solution.

My tts configuration in configuration.yaml:

tts:
  - platform: google_translate
    base_url: http://192.168.178.222:8123
    language: 'nl'

The Google Home device has to connect to its Home Server (Google) and I found via community posts that there is a (reverse) DNS problem why it is not working. But I do not understand exactly what the problem is and what I can do in my configuration te solve this.

I read at some discussions that there should be files in the /tts folder, but my folder is empty!

I place dthe Media Control Card in the UI and selected the Google Home device. This works, it shows the radio station or Spotify album I order it to play. But when type something in the
Text to speak field, nothing happens.

Because I was thinking about the reverse DNS for the Google Home I allso tried with adding the Google DNS servers in the AdGuard Home configuration
Upstream DNS servers

Enter servers addresses one per line. Learn more about configuring upstream DNS servers. Here is a list of known DNS providers to choose from.
https://dns10.quad9.net/dns-query
8.8.8.8
8.8.4.4

Hopefuly someone ia able to help me with this…

Please let me know if more info is needed

There is an issue with this platform at the moment. A fix has been merged and will be available in the next release.

Hi Tom,
Thank you for your reaction. In the GitHub page I read that this issue started a couple of days ago, possibly related with version 0.118.4. However my issue is much older, actually it has never worked :frowning:
But because I am now trying to get the Alarm Panel with automation running, I wanted to use the Google speaker. So, it was about time to look at tss.

I think I will first to have to wait until this issue has been solved before I can try to make tss work.
But I am afraid that there is a DNS issue with my config, using a strange port number for access from Internet… Lets wait for the fix first.
Regards, Bert

I will try the fix which is described in tat GitHub page…

Did the fix this afternoon, but I did not got tts working. Later this afternoon version 0.118.5 was released with a fix for tss, so I removed the fix, restarted hass and upgraded to v 0.118.5.
But still tts is not working.
The situation is as following. I can give Google Assistant a voice command to play f.i. a radio station. Google does play that station and it is visible in the Media Control Card in Lovelace UI. Also switching off and on the Google Home from the Media Control Card works OK. By switching on, I also hear the Google Home Blieb.

But when I want to use the Text to speak field in the Media Control Card, that does not work! I’l get this error message in the lower left corner:

Failed to call service service tts/google_translate_say. No text to speak

Any help is much appreciated

This is what my configuration.yaml looks like:

tts:
  - platform: google_translate
    cache: false
    cache_dir: /config/tts
    time_memory: 60
    base_url: https://<mydomain>.duckdns.org
    service_name: google_say

Before I installed and configured NGINX I appended the :8123 to the base_url value, but that is no longer necessary as with NGINX I’m forwarding external port 443 to my HA port 443. It looks to me like you’re trying to tell the Google tts service to send the generated .mp3 file to http://192.168.178.222:8123, but that isn’t accessible from outside your network.

Hi @mightybosstone, you are absolutely right! I have to use the externa IP@ where Google is able to find my Google Home device on! Eurlier, i did try it with my DuckDNS@ but used port number 8123. But since I am using an other port translation in my router (44001 - 8123) I have to use port 44001. And that works OK!
So I am using your config now with the following changes

    base_url: !secret external_url

And in my secrets.yaml:

external_url: https://<my-dns-name>.duckdns.org:50001

Thank you for pointing me to my mistake!