Lost hassio menu item

Probably a silly mistake on my part, but can anyone explain how I might get the Hassio menu item back

image

Following an update to 0.81.2 my system became unstable (aka dead and unresponsive) so I did a compete re-install. On the initial install I had the menu item and was able to install the usual SSH etc components. When I restored my main config files the menu item has disappeared and I have no idea how to get it back. Grateful for some guidance?

You need either:
discovery:
hassio:
In the configuration yaml

brilliant, thank you, was tearing my hair out there.

I had the same issue, thanks

but discovery: is not necessary
I simply add hassio: to my configuration.yaml

As I said add either not both

well, that can be tricky.
though discovery: ought to discover hassio too, it is not as robust as simply adding hassio:.

then again hassio: doesnt take care for the discovery of the other discoverable components, so for that you need discovery:…

in the end, one needs both in a sensitive system.

The docs say you can just use discovery which is what I’ve used for over a year with no problems.

Isn’t it amazing how far this platform has come since we started using it?

1 Like

well ymmv of course.
it all boils down to the difference between theory and practice. And the docs aren’t always right :wink:
Many many posts here about this subject a least suggest the Hassio menu isn’t as stable as one would have hoped for.

the docs also say Hue integration is platinum…

I think sometimes people conflate various issues and find something that works while ‘forgetting’ that something else was screwed up with something else previously when they tried something. Certainly the hassio menu/panel has disappeared with a couple of updates and needed a cache deletion or a hassio update to fix.

I think that’s most likely what you are seeing when you describe this.

As I say I have been using discovery for a year - actually I have never even tried hassio: - only discovery and unless there was a bug or ‘instructions’ to delete all content when they refreshed the frontend I have never had an issue.

If I wasn’t using discovery for other components though I would just use hassio. There is no reason to use both.

sure, works for you. And you might be right.

Reading the community posts on this subject would at least suggest this is an issue to be ironed out before we finally reach version 1.0…

till that moment, using hassio: can assist for those use cases you describe. And is reason to use both.

The mythical 1.0.

Thanks guys, this is clear for me now. My use case was I wanted to stop auto discovery, but I didn’t realise the impact on the hass.io menu, so now I know hassio: in the config file gets me what i want. When I want to bring back auto discovery I’ll re-instate discovery: Thanks for the advice, very much appreciated.

1 Like

ok cool.
be ware though this is still happening:

2018-11-03 11:20:53 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /discovery request
2018-11-03 11:20:53 ERROR (MainThread) [homeassistant.components.hassio.discovery] Can't read discover info: 

Ive posted it on the GitHub, but no response received. Not sure what it means, or why this is happening, nor what the consequences are…

as a big bump:

still on 0.94.3:

2019-06-18 13:47:23 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /discovery request
2019-06-18 13:47:23 ERROR (MainThread) [homeassistant.components.hassio.discovery] Can't read discover info: 

Did you ever figure this out? Still getting it myself on 0.103.6 and don’t know what is causing it.

no, it is still there.
Ive filed a issue, might have forgotten to update it there, but fear the dev’s don’t really take it seriously enough .

2020-01-13 08:01:04 INFO (MainThread) [homeassistant.core] Starting Home Assistant
2020-01-13 08:01:18 INFO (MainThread) [homeassistant.core] Timer:starting
2020-01-13 08:01:22 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /discovery request
2020-01-13 08:01:22 ERROR (MainThread) [homeassistant.components.hassio.discovery] Can't read discover info: 

you might want to add to https://github.com/home-assistant/home-assistant/issues/30751, so this could get some traction again.

What exactly is your problem? No hassio menu? Or a relatively harmless error message?

we don’t know don’t we? Whether this is harmless. Harmless would be a warning, and even then this would be better solved, if possible.
being an error, it needs to be.

1 Like

Just the error message. Been getting it for a while now. Just curious if anyone ever figured out what it was causing it. Everything appears to be in working order.