Lovelace: Waze Card


#1

Waze Card

Show distance and duration for a list of Waze routes and click on Waze route to open Waze app

Source

Features

  • Show distance and duration for a list of waze routes
  • Click on route to open Waze app
  • Show best route to take
  • Supports metric and Imperial systems

Options

Name Type Requirement Default Description
type string Required custom:waze-card
header boolean Optional true show header
title string Optional Waze Routes Header text shown at top of card
entities object Required List of routes to display
columns list Optional name, distance, duration, route Which columns to display

`entities` Options:

Name Type Requirement Default Description
entity string Required The waze sensor entitiy to use
zone string Required The zone to map the route with
name string Optional friendly_name from Waze config The name of the route
resources:
  - url: /local/waze-card/waze-card.js?v=1.0.0
    type: js
- type: custom:waze-card
  entities:
    - entity: sensor.waze_home
      zone: zone.home
      name: Home
    - entity: sensor.waze_work
      zone: zone.work
      name: Work

#2

Up and running. Works great!


#3

good job.:slight_smile:


#4

Is there any way of getting info in the card if there is an accident reported on the specified route?


#6

No sorry the data I get back is limited by the Waze API


#7

One thing I have noticed is that I am not seeing this card show up in the tracker card even though I have included the link in LL config that should add it to card updater


#8

Just fixed. This is my first card so I wasn’t sure how to get that all working.


#9

Was it a fix to the Json file or something I need to download or change in config?


#10

No, nothing you need to do on your end. I just needed to add a release tag to my repo so the updater can pick it up.


#11

Not sure why, but just got home and it is still not showing up in the tracker-card. I manually updated to 1.1.0, confirmed the link was correct in:

custom_updater:
  card_urls:
    - https://raw.githubusercontent.com/kuuji/button-card/master/tracker.json
    - https://raw.githubusercontent.com/ljmerza/waze-card/master/updater.json

Yet still not there.


#12

Could you try restarting HA? Looks like the version control is tied to the custom_updater component and that has to be reloaded.


#13

I have restarted and no change


#14

ok haven’t forgotten about this. I’ll definitely figure it out and update everything


#15

Hi, Is there any way for it to display in miles? Mine seems to be set to Km.

Thanks


#16

works great thanks


#17

Hey yeah it should be based on your global home assistant settings.


#18

Thank you, Can’t believe all the months I have has HA and had unit of measurement set to Metric :smiley:

Thanks for the card, I like it a lot.


#19

After looking closer,

It displays mi now but the numbers it displays is still km? So, it shows 63.71mi but should show 40.1mi.


#20

Ok I made an update to v1.1.1 and it should work. Let me know thanks!


#21

Hello, thanks for the component. there is an error with the distance in metric units. the distance attribute is already in km in my case and does not need to be converted anymore. Also I don’t understand why I have to specify the zone. Thanks in advance