Lutron Caseta integration issue after update to 2020.12.7

Tags: #<Tag:0x00007f325e4f6a90> #<Tag:0x00007f325e4f6978> #<Tag:0x00007f325e4f66f8>

Hello,

My Lutron Caseta integration stopped working after I updated to 2020.12.7 and I’m looking for ideas on how to fix. I’m running Home Assistant Supervised on an RPi4 - with Raspberry Pi OS (Raspbian GNU / Linux 10 (buster)).

I’ve tried the following (in order) and included my configuration yaml entry and HA log output below.

  1. Removed Lutron Caseta integration, YAML entries and cert files; restarted HA; added YAML entries and cert files back and restarted HA.
  2. Performed a completely new install: new OS image (2020-12-02), new HA install, generated cert files (using a get_lutron_cert.py file downloaded on 12/17) and placed in usr/share/hassio/ssl/lutron directory and added lines below to YAML. Restarted HA.
  3. Followed steps that resolved the similar issue discussed here - File Path for certificates on Lutron Caseta Component

Each time my YAML entries were:
#Lutron

lutron_caseta:
  - host: IP_ADDRESS
    keyfile: caseta.key
    certfile: caseta.crt
    ca_certs: caseta-bridge.crt

The result was the same each time:

  • The Lutron Caseta integration showed in my integration list after restart but when I tried to configure it I received the message: Failed to import Caséta bridge configuration. Couldn’t setup bridge (host: [ip of my lutron hub]) imported from configuration.yaml. Failed to connect

  • The error reported in the HA log was consistent as well:
    Logger: homeassistant.components.lutron_caseta.config_flow
    Source: components/lutron_caseta/config_flow.py:84
    Integration: Lutron Caséta (documentation, issues)
    Unknown exception while checking connectivity to bridge [ip of my lutron hub]
    Traceback (most recent call last):
    File “/usr/src/homeassistant/homeassistant/components/lutron_caseta/config_flow.py”, line 84, in async_validate_connectable_bridge_config bridge = Smartbridge.create_tls( File “/usr/local/lib/python3.8/site-packages/pylutron_caseta/smartbridge.py”, line 106, in create_tls ssl_context.load_verify_locations(ca_certs) FileNotFoundError: [Errno 2] No such file or directory

Any help is appreciated!

I would double-check the ip address of your bridge in the Lutron App to be sure. I am using a rpi4 and this is my configuration:

lutron_caseta:
  host: 192.168.x,x
  keyfile: /ssl/lutron/caseta.key
  certfile: /ssl/lutron/caseta.crt
  ca_certs: /ssl/lutron/caseta-bridge.crt