Lutron RA2 12.2.1 problem

Can get Lutron RA2 12.0.1 to work, but 12.2.1 hangs HA during boot.
Anybody with similar problem?

whew, im glad I googled this before upgrading to 12.2.1. Are you aware if Lutron publishes the changelog? have you opened an issue with pylutron yet?


No issues filed.

I have two instances of HA running, one running Lutron 12.0.1, about to add another repeater to 2nd HA.

Updated a repeater to 12.2.1, configured it in Lutron’s desktop app with simple one switch configuraton, but it hangs HA on boot. Tried connecting the repeater to the working HA, same problem.

Lutron support said I can/should be able to downgrade repeater to earlier software (12.0.1 in my case), but it fails despite many attempts. Did speak with Lutron support, they say bricked repeater…

Sooo, I ordered another repeater to try, will be here in a few days. Will try 12.0.1 to see how it goes, will post here.

I think it is a 12.2.1 problem, failure to downgrade firmware, but, Lutron desktop can download config to repeater successfully. I am hesitant to try upgrading another repeater to 12.2.1, time and money is precious, regretfully. At $200/per test, this could get expensive fast.

hm, keep me posted. I’ve been helping review stuff lately with pylutron, and have been working with @thecynic to iron out some bugs recently

Jon, thank you for your ping.

I did receive another repeater. It was on 11.0, upgraded to 12.0.1, programmed it up and it works on both my HA setups.

Not sure what to make of this, the “broken” unit on 12.2.1 does take programming, but will not downgrade.

If you have something you would like for me to test, please let me know.

Thank you for your efforts, are you working on getting Pico’s exposed?

I have 12.2.1 working here. All I can think of is that the default behavior for 12.2.1 is to delete the “standard” telnet credentials. Make sure that your credentials in your configuration.yaml are functional.

Wow, great pointer. The default account and password is no longer set by default. Add user and password by going to Settings/Integrations and add a user/password.

12.2.1 now does NOT stop booting of HA and devices work; thank you !!!

@jon102034050 HA’s Lutron integration should report invalid Lutron login rather than freezing HA during boot.

Now, maybe that is related to not taking a repeater firmware downgrade, will test.

1 Like

Tried various ways to downgrade the firmware for RA2 repeater from 12.2.1, -while making sure the previously standard Lutron-integration account was defined under 12.2.1, still cannot downgrade.

The repeater works fine when used with 12.2.1 (no other apparent issues).

I haven’t been, but I’ll give it a look. I only have 1 pico, and didn’t honestly realize it wasn’t recognized by HA because I only use it to remotely turn on some lights, not trigger actions.

I’ll check into this behavior - I thought I tested this and it didn’t halt HA boot, it just didn’t setup the integration, but something may have changed recently because there have been changes around error handling and such.

@Dansker - Please take a look at this PR. Martin has already approved it, and it will expose Pico’s in HA.

Fantastic, I’ll definitely give this a try. THANK YOU, I’m sure many RA2 users will be grateful.

When do you think this will make it into HA ?

No prob :smiley: Looks like approval already happened, but it hasn’t been merged yet. I imagine it’ll make it into the next release. I think the next one is the major 0.100 milestone, so it could be delayed because of this, not sure really. I’ll keep you updated.

@Dansker - PR hit some roadblocks, but it finally got merged. It’ll hit the next release.


Thanks for the update, will check it out.

@jon102034050 Finally getting to check out the new Lutron RA2 Pico keypad support. The docs on the lutron events are a bit scant; in particular the various key names.

Could you provide an example to get me going, or maybe I missed the docs?

Thank you !

Can you clarify what you’re trying to accomplish? I assume what you’re looking to do is trigger an action off of a pico button press? If so, I don’t know that this is possible in it’s current implementation. What you can do is perform the actions that the pico does through HA with another trigger though


I am trying to pick up a Pico keypress inside HA, that is, use a Pico keypad to trigger something in HA…?

The docs talks about Lutron events, that suggest a keypress generates a HA event ?

Thank you.

Sorry - I misspoke earlier, thanks for pointing the lutron_event out to me! Here’s an example of an automation for when I push a button on a pico.

- alias: "test scene notification"
    - platform: event
      event_type: lutron_event
        id: office_pico_on
        action: single
    - service: notify.telegram_jon
        message: "pico on"

You can pull info from these events by listening for them via the UI:

Then, press the button you want to capture.

EDIT: made a PR against the lutron docs to hopefully help others out:


Thanks a lot, works here for me !!!