Material Design Icons for groups

Switches and toggles have MDI icons now which is very nice but it would also be good if groups could have icons too.
For example, a group for a desktop PC could have the “desktop-tower” icon and a group for the kitchen and living room could have the “food-variant” and “television” icons respectively. It may be a bit cluttered in some peoples eyes but for others it may look quite nice. :slight_smile:

You can do that using the customize section: home-assistant.io/getting-start … d-services

I tried that but it didn’t work. :-/
I’ll try again later with a different group and see if it works. :slight_smile:

Icons for groups will not be shown on the card itself but only in the more info dialog. And one would only be able to see the more info dialog of a group if you add that group to another group.

Verifying if your customize config works is as easy as going to the dev tools -> states and looking at the group state.

OK, nice!
Would be cool if there would be icons next the labels at the top of the cards too, but I guess it won’t look too pretty. It’s always a choice though, so if the user doesn’t want one there they don’t have to use one. :stuck_out_tongue:

I like @GreenTurtwig idea… kinda of OCD here! I wen through your config.yaml example… no idea how you integrated the television.pgn from images into the final product.

Im trying to add icons or pictures to my known-devices.yaml, but I think thats not the easiest way to go (or correct, for that matters, perhaps I need a separate cuztomize.yaml?)

I want to give a custom icon to my router:
ie: router @ ip 1.2.3.4

I did:
-added folder .homeassistant/pics/
-dumped a bunch jpg and jpeg into the folder (router.jpg is one of those… )
-updated known-devices.yaml…

if I understand the instructions and @balloob correctly, I would need something like:

A:
customize:
router:
hidden: false
entity_picture: /pics/router.jpg
friendly_name: router

I tried to hide a group created within configuration.yaml called group.sideboard:

customize: group.sideboard: hidden: true

While starting home.assitant I get the following error message:

Unable to find component customize

Thanks for any insights!

the customize-part of your config must be inside the homeassistant-part

homeassistant:
  customize:
    group.sideboard:
      hidden: true

Perfect, works fine on hiding the group.

Somehow, it does not fly to change the icon of device_tracker.

customize: group.sideboard: hidden: true device_tracker.iphone icon: mdi:cellphone-iphone

Actually, this setting prevents home.assistant to start again.

Any idea why this could be the case?

The customization-syntax seem correct. Though i haven’t tried to change the icon myself so cant comment about that.
If HA isn’t starting you should get a reason of that in your home-assistant.log in the root folder. Check that out, if you have trouble solving the problem, attache the log here and i or someone else might be able to help out.

Thanks, problem solved and works fine as expected.

Formatting like this should solve it


  customize:
    group.sideboard:
      hidden: true
    device_tracker.iphone
      icon: mdi:cellphone-iphone