Media folder on SMB?

Can’t get to this with media library. Is it possible that you cant refer to any library outside the hardware you run HA? I run in a regular network. SMB works and I see everything from my Windows 10 PC. In HA (on PI) I have tried in every way to get to the media library on a USB disk in the network.

 media_dirs:
   smb: // bio / TOSHIBA EXT / FilmUSB
   smb: \\ bio \ TOSHIBA EXT \ FilmUSB
   http://192.168.1.XXX:8080/movies

None of these three examples work. Only find out when I test the configuration that the media library is not valid. What am I doing wrong?

Checking, but do you actually have that spacing in between words and slashes in your config?

Maybe mounting it?

The docs only show local paths, not network paths or URIs. Given the language of the integration docs, I’d be pretty confident it only supports those local paths, so as @mcarty said, you’ll need to mount those.

Thanks guys, yes maybe you right.
Sorry about the spaces, they are not there IRL, something happened when copy and paste.
So what you mean is to mount the SMB hard drive in my network on to my PI (where I run HA) and the refer to it as a PI local disk. Haven’t done that before… My PI is a pure HA machine meaning I never (normally) log into it on ssh/root level which I suppose i need for the mounting? Or can that be done in some way in HA? No?
If you or anybody else have a link for this operation it’s highly appreciated.
Thanks