Messed up my containers

I will start with I don’t know much about docker. I have installed docker on an existing Ubuntu server and have been running HA/Supervisor for a few weeks with no issues. Long story short, I was troubleshooting something else and during that I shut down all containers via docker stop $(docker ps -q). I did not know that I should not have done that, nor did I get a list of images running before I stopped them. Now I can’t seem to start the containers. I ran docker images but when I try to start the images using the listed ID’s none of them will start. I found the command:

docker run -d --name=“home-assistant” -v /PATH_TO_YOUR_CONFIG:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant:stable

but I don’t know what the PATH_TO_YOUR_CONFIG should be. Any pointers? Or am I screwed?

Try running

docker ps -a

That should give you list of all your docker containers

Then do a

docker start <container name>

on each one to restart them

1 Like

Cheers, looks like that worked, thanks!

Install portainer and read docker docs

Portainer will give you a docker UI
DOCS will give better understanding

1 Like


that was the next thing I was going to suggest right after I knew that everything was working again.

Thanks to you both, I’ll setup portainer. Sometimes it seems that docker is almost too easy, so I’ve skipped getting into it too deeply, I’ll definitely educate myself.

1 Like