MFA Not Working after Restoring Home Assistant Snapshot

I am moving my HA build from one device (Windows) to another (MacOS)…

Since both devices run in Virtualbox, my initial thought was to just use the VDI file from the old machine, in the new one, but this didn’t work (still not sure why, but that’s a different topic all on it’s own).

Then I thought I’d use my snapshot and just restore it on the new machine.

This worked fine and HA boots up and I need to put in my Username and Password, then do MFA.

At the MFA stage, I put in the 6 digits from the Authenticator app and it just says

Invalid authentication code

I can’t see that this shouldn’t work… So I am not sure what to do about it.

Is the time and time zone set correctly?

Thank you for the quick reply…

What device / place are you referring to for the time and time zone settings?

If on the Mac, then yes, it’s correct.

If on the HA installation, I can’t access it, so I cannot confirm. But on the Windows machine, it was correct.

The host machine and Home Assistant.

You may find some assistance here:

Okay great, thank you.

Will give it a try and get back to the thread after. :slight_smile:

@tom_l

Thank you for your help on this thread. The issue is sorted now, but I actually didn’t change anything… I switched off the VM, started it up again and then the MFA just worked…

Anyway, thank you again for your help :slight_smile: