Modbus sensors stop working after some time running. This issue starts after I change from HA supervised to HASSOS 4.17

Hi communnity, this is my first post, I hope doing everything correct, and in the wright place :slightly_smiling_face:

My setup:
Home server, running ESXi 6.5, with 1tb HDD, 16Gb RAM, i5
1 VM with LinuxMint19, running HA 0.117.0 --> This one is running without any problem, its ok
1 VM with HAssOS 4.17 running HA 0.118.5, Supervisor 2020.12.6 --> this one can´t communicate with modbus devices

The problem
My first Virtual Machine running over Linux is running ok, I only made a new virtual machine, because i have to, to allow me to update to version 0.118. I tried to update, but the HA supervises on top of Linux don’t allow it anymore, so I made a new virtual machine using the vmdk/ova VM files, downloaded from from the site with HASSOS 4.16, and then I made the update to 4.17 and 0.118.
At the moment I’m running both VMs, so I have two instantes of HA, one of them continue to communicate with my PLC by modbus tcp, and the new one, with the same configuration, after some minutes, or hours stop communicating. The modbus sensors reports “unavailable”

some images to help understanding the problem:
modbus sensors not healthy, after some time running:
image

The last two sensors, I have created only to chek if the problem occurs only with my PLC, I only need to communicate with the PLC using modbus, so, usually I only have 1 modbus hub, now I created two new ones, and the problem is the same with the new ones.
I tried to remove all AddOn’s, using HAssOS4.16 or 4.17, HA0.117 and 0.118.5, and my conclusion is that with the HASSOS I allways have the problem. The other HA installation over LinuxMint, is running for a long time, over two years withou any problem.

configuration yaml:

# MODBUS connections ---------------
modbus:
  - type: tcp
    host: !secret PLC_Sch_IP
    port: !secret PLC_Sch_port
    name: PLC_Schneider
  #timeout: 5

  - type: tcp
    host: 192.168.1.155
    port: 502
    name: AE_ABB
  #timeout: 5
  - type: tcp
    host: 192.168.1.153
    port: 502
    name: AE1

logs
In the logs I have the following:
2020-12-12 20:13:36 ERROR (SyncWorker_4) [pymodbus.client.sync] Connection to (192.168.1.160, 502) failed: timed out

2020-12-12 20:13:36 ERROR (SyncWorker_11) [pymodbus.client.sync] Connection to (192.168.1.153, 502) failed: timed out

So the problem is on the pymodbus.
How can I solve this issue?
Someone have the same problem?

Update info @2020/12/18: The problem remains with the latest updates, HASS OS 5.8 and HA version 2020.12.1

Thanks in advance.
Cláudio Costa

Just for information, I decided to install a VM with Debian 10 (instead of Ebuntu or HASSOS, and the problem of modbus communication was solved.