Modding existing add-ons?

I am trying to modify an existing add-on (influxdb), since there are 4 binaries in there which compiled for arm32, and architecture my arm64 aka aarch64 CPU does not support. I have compiled the binaries (and submitted pull requests to the influxdb project).
I tried to git clone the influxdb addon, put it in addons/local, but even before I change anything, it always gives me: Failed to install addon, unknown error, see logs.
But there is nothing in the home assistant log.
So what am I doing wrong her, if even a clean git clone of an add-on does not work ? Do I have to avoid some naming conflict with the included add-ons ? Ports ? Are errors elsewhere ? The logs I can see from HomeAssistant in Portainer has nothing either.

Maybe the Supervisor logs?
Supervisor -> Tab System

Found it there. Error 100.
Never noticed that log before.
When I tried to build container manually, I found 2 issues, one is Dockerfile had ARG BUILD_ARCH=amd64 - This is no good on ARM.
And package was not the newest version thus failing. But the GitHub repo I just clone supposedly had the update (12 hours ago), but for some reason my clone did not. That fixed, and influxdb runs.

1 Like