Mopidy and snapcast add-on

I cant seem to make it work.
My client does not connect

pipe:///tmpfs/snapfifo?name=default
2019-10-11 21-35-26 [Notice] Settings file: "/root/.config/snapserver/server.json"
2019-10-11 21-35-26 [Err] Error reading config: [json.exception.parse_error.101] parse error at 1: syntax error - unexpected end of input; expected '[', '{', or a literal
2019-10-11 21-35-26 [Err] Failed to create client: Daemon not running
2019-10-11 21-35-26 [Info] PcmStream sampleFormat: 48000:16:2
2019-10-11 21-35-26 [Info] metadata={
2019-10-11 21-35-26 [Info]     "STREAM": "default"
2019-10-11 21-35-26 [Info] }
2019-10-11 21-35-26 [Info] onMetaChanged (default)
2019-10-11 21-35-26 [Info] PipeStream mode: create
2019-10-11 21-35-26 [Info] Stream: {"fragment":"","host":"","path":"/tmpfs/snapfifo","query":{"buffer_ms":"20","codec":"flac","name":"default","sampleformat":"48000:16:2"},"raw":"pipe:////tmpfs/snapfifo?buffer_ms=20&codec=flac&name=default&sampleformat=48000:16:2","scheme":"pipe"}
2019-10-11 21-35-26 [Err] (PipeStream) Exception: end of file
INFO     Starting Mopidy 2.2.2
INFO     Loading config from builtin defaults
INFO     Loading config from /var/lib/mopidy/.config/mopidy/mopidy.conf
INFO     Loading config from /var/lib/mopidy/.config/mopidy/mopidy_cast.conf
INFO     Loading config from command line options
INFO     Creating dir /root/.config/mopidy
INFO     Enabled extensions: iris, mpd, http, file, stream, m3u, softwaremixer, moped, local-images, local, local-sqlite
INFO     Disabled extensions: spotify, gmusic
WARNING  Found gmusic configuration errors, the extension has been automatically disabled:
WARNING    gmusic/username must be set.
WARNING    gmusic/password must be set.
WARNING  Found spotify configuration errors, the extension has been automatically disabled:
WARNING    spotify/username must be set.
WARNING    spotify/client_secret must be set.
WARNING    spotify/password must be set.
WARNING    spotify/client_id must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO     Found 762 files in media_dir.
INFO     Checking 762 tracks from library.
INFO     Removing 0 missing tracks.
INFO     Found 0 tracks which need to be updated.
INFO     Scanning...
INFO     Scanned 0 of 0 files in 0s.
INFO     Done scanning.
INFO     Starting Mopidy 2.2.2
INFO     Loading config from builtin defaults
INFO     Loading config from /var/lib/mopidy/.config/mopidy/mopidy.conf
INFO     Loading config from /var/lib/mopidy/.config/mopidy/mopidy_cast.conf
INFO     Loading config from command line options
INFO     Enabled extensions: iris, mpd, http, file, stream, m3u, softwaremixer, moped, local-images, local, local-sqlite
INFO     Disabled extensions: spotify, gmusic
WARNING  Found gmusic configuration errors, the extension has been automatically disabled:
WARNING    gmusic/username must be set.
WARNING    gmusic/password must be set.
WARNING  Found spotify configuration errors, the extension has been automatically disabled:
WARNING    spotify/username must be set.
WARNING    spotify/client_secret must be set.
WARNING    spotify/password must be set.
WARNING    spotify/client_id must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO     Starting Mopidy mixer: SoftwareMixer
INFO     Starting Mopidy audio
INFO     Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
INFO     Audio output set to "audioresample ! audio/x-raw,rate=48000,channels=2,format=S16LE ! audioconvert ! wavenc ! filesink location=/tmpfs/snapfifo"
INFO     Loaded 762 local tracks using sqlite
INFO     Starting Mopidy core
INFO     Starting Mopidy frontends: IrisFrontend, MpdFrontend, HttpFrontend
INFO     Starting Iris 3.33.0
INFO     MPD server running at [::ffff:0.0.0.0]:6600
INFO     Starting GLib mainloop
INFO     HTTP server running at [::ffff:0.0.0.0]:6680

I think you are in the wrong section here. This doesn’t look like an AppDaemon app.

sorry, fixed it

Hello again,

  1. I have rpi 3b+ with hass.io and mopidy + snapcast server add-on
  2. I have another rpi 3b+ with snips and mopidy + snapclient

Snips works great and speaks
the problem is that snapclient doesn’t seem to work.
Service is running, but i’m not sure it is connected to the server and i also don’t know how to enable / configure both snips and snapclient to output sound.

HELP - I’m trying to solve this for over a week with no luck

How did you fix this? I’m having the same problem.

Didn’t solve it, instead i switched to lms