MQTT – all Tasmota Switches via MQTT switch on instead of just one

I have four Gosund SP111 which I have successfully flashed with Tasmota… I have set up MQTT on hassio and via Autodiscover all 4 switches have been found by hassio. They are named Tasmota01, Tasmota02,…

But when I click on Overview of discovered devices, go to MQTT and chose one of the four, and than click “switch on” all four switche to “on”.

And all the data “Tasmota01 Energy Total”… is for all four the same. What can I do to separate them in hassio?

When I access one of the with its IP I see the correct data and can switch just the chosen one.

Any idea, what I am doing wrong or what I do have to check?

I have the same problem. How did you solve the problem ?

In my case the problem was sitting in front of the computer … :wink:
Under MQTT settings I had to spercify different topics - I named the Tasmotas with the device names “Tasmota01”, “Tasmota02”,… so I had to enter in the topic “Tasmota01” and for the next one “Tasmota02” and so on in the MQTT settings as well. Now it is working fine.

Thanks so much for your reply .

1 Like