MQTT has 2 entries for Zigbee2MQTT entities


I run Home Assistant since 1-2 years with MQTT and Zigbee2MQTT quite successfully with 40-50 Zigbee devices.
Last day I rebooted the VM containing HA and all my Zigbee devices got unavailable.

In Zigbee2MQTT, all devices are there as expected.
So I go to entities and here is the problem. All Zigbee/MQQT entities are there twice, for example:
And so on.

I could (maybe not successfully, delete every “old” entity, then rename the new one to old one). With ~50 Zigbee devices and 3-5x more entities, it’s a lot of work and will break some things.

The only thing I can think of is I moved the configurations files of Zigee2MQTT from \share\zigbee2mqtt to \config\zigbee2mqtt some weeks ago. Since then, I had updates, reboots successfully.

I restored the VM 1 day before to come back to a “clean” situation, but I can’t reboot as is as the problem will come back…
And strange thing happens with the config of Zigbee2MQTT; I changed the basetopic from zigbee2mqtt to homeassitant some days ago without any particular side effects.
Now, when I open the config o Zige2MQTT in the GUI, I get:

data_path: /config/zigbee2mqtt
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
  base_topic: zigbee2mqtt
  port: tcp://

But if I open the file from the Samba share I get:

external_converters: []
  - devices.yaml
  - groups.yaml
homeassistant: true
permit_join: false
  base_topic: homeassistant
  server: mqtt://core-mosquitto:1883
  user: addons
  password: zzz
  reject_unauthorized: true
  include_device_information: true
  keepalive: 60
  version: 4
  port: tcp://
  log_level: info
  pan_id: 6754
  channel: 11
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
  last_seen: ISO_8601
  elapsed: true
device_options: {}
blocklist: []
passlist: []
queue: {}
  port: 8099
experimental: {}

So I’m not really sure how this is possible???

I’m on HA Core 2022.10.3.


Same thing just happened to me after applying 2022.12…did you find a fix for this or do I have to rename all the entities?