MQTT/OwnTracks broken since 0.39.0

Ever since upgrading to 0.39.0 (and now 0.40.0) my presence setup has been completely broken. Within OwnTracks, I can still see all of my devices on the map, but they’re not updating HASS and so none of my automation is working. (I originally used the All-in-One Installer about 6-8 months ago and have been updating regularly.)

I have upgraded my rPi’s firmware as the 0.40.0 blog post states, but that has not helped.

Checking the status of the service shows some oddities.

pi@Jarvis:/home/hass $ systemctl status mosquitto.service
● mosquitto.service - Mosquitto MQTT Broker daemon
   Loaded: loaded (/etc/systemd/system/mosquitto.service; enabled)
   Active: activating (start) since Sun 2017-03-12 23:26:59 UTC; 39s ago
  Process: 6278 ExecStart=/usr/local/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf -d (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/mosquitto.service
           └─6279 /usr/local/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf -d

I’m not sure where to go from here in terms of troubleshooting.

Odd, using OwnTracks with MQTT and zero issues here on 39 and now 40.

I should add, here’s my presence configuration:

mqtt:
  broker: localhost
  port: 1883
  client_id: ha
  keepalive: 60
  username: ha
  password: ha
  protocol: 3.1

device_tracker:
  platform: owntracks
  max_gps_accuracy: 200
  consider_home: 180

And I have rebooted the pi several times.