Music playback to Google Nest hub/Google Mini stops after about 20 minutes

I am running HA 0.116.4 as VM. I have added one music file test.mp3 to the /media folder. This file is visible in Media Browser. When I had installed HA, it automatically discovered Google Nest Hub and two Google Mini devices. I did not do anything specific to add these devices. I have Nabu Casa subscription. No other special network configuration.

When I select the media file and select any of the Google players, the file starts to play. After about 20 minutes, the file stops playing. At the same time, I see a Notification in HA:

Login attempt failed
Login attempt or request with invalid authentication from localhost (127.0.0.1) (Mozilla/5.0 (Linux; Android) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36 CrKey/1.50.229149)

In the HA logs, I see the following message:

Log Details (ERROR)
Logger: homeassistant.components.cast.media_player
Source: components/cast/media_player.py:383
Integration: Google Cast (documentation, issues)
First occurred: 2:32:47 PM (1 occurrences)
Last logged: 2:32:47 PM

Failed to cast media https://....ui.nabu.casa/media/local/test.mp3?authSig=<long key> from external_url (https://....ui.nabu.casa). Please make sure the URL is: Reachable from the cast device and either a publicly resolvable hostname or an IP address

What could be the issue? It is happening consistently. It has been happening since Media Browser was introduced in HA.

Thanks…

1 Like

Hello, i have the same issue here. Did you find a solution for the problem?

No, it never got resolved. So, I divided the songs into groups of less than 20 minutes each. I play one group of songs, then send a power off/power on to Nest, then play group 2, then send a power off/power on and so on. Not good, but nothing else I can do.

I found a issue on Github and got help there. They fix it for next point release, 2021.4.2.
But its just a smal change so i tryed it and it works:-)

Thanks. I tried to search for media_player.py, but could not find any such file. There isn’t even a components directory anywhere. I am running HA in a VM. Will wait for the 2021.4.2 release.

try docker exec -it homeassistant /bin/bash at vm console to connect to the container, then you should find it at /usr/src/**homeassistant/homeassistant**/components/cast
the path might differ a little bit depending on your installation…

Have a good night!

Thanks for teaching me something new. It worked perfectly.

But 2 hours later, 2021.4.2 came out…!!!